HCL - Tuxedo InfinityBook S 15 - Gen8 (NS50AU)

TL;DR: Some tweaking required, but no major showstoppers :slight_smile:

1. Working out of the box:

  • Installation
  • Boot into system
  • Graphics
  • Keyboard
    (via i8042/serio aka PS/2 → no need for USB input devices)
  • Touchpad
    (also i8042/serio and i2c)
    Hint: The touchpad has a physical click-switch. If you prefer tap-to-click, it can be enabled in the dom0 system settings.
  • Audio in and out
    Note: Not Qubes-related, but the speaker quality is surprisingly bad, sounding like out of a tin can. Quick test seems to indicate at least 12dB attenuation below ~1kHz.
  • Webcam (via USB)
  • Ethernet
  • Wifi
  • HDMI out
  • Bluetooth (appears as USB device 8087_0033)

2. Not working:

  • microSD cardreader
    • The Installer does not assign it to any Qube.
    • I can for example attach it to sys-usb, but I get the kernel message “probe with driver sdhci_pci failed with error -22”
    • Workaround: Use external USB cardreader (-> no showstopper for me)

3. Tweaking needed:

  • Keyboard backlight

    • You need Tuxedo’s kernel module
    • → You now have the control interface in /sys/class/leds/white:kbd_backlight
      → and you now get X keyboard events KbdBrightnessUp, KbdBrightnessDown and KbdLightOnOff
    • As stated in Tuxedo’s README, you’re on your own how to make your desktop environment react to the keypresses and change the brightness.
      • I used “System Settings” → “Keyboard” → “Shortcuts” to bind the keys to a small python script based on the Upower example from Keyboard backlight - ArchWiki. If you have a more out-of-the-box suggestion, please share it.
  • Suspending
    (… you’ve all been waiting for this one, right?)

    • Good news: S3 / Suspend-To-RAM / “deep” still works!

    • However, the kernel default is s2idle
      → You need to set kernel parameter “mem_sleep_default=deep”
      (add that to GRUB_CMDLINE_LINUX in /etc/default/grub and regenerate your grub config: grub2-mkconfig -o /boot/grub2/grub.cfg)

    • Note: I disabled Intel ME and Hyperthreading in the firmware setup.

    • → All devices seem to resume properly, except

      • Ethernet
        • The ethernet device is still there after resume, but it does no longer recognize the link
        • Un- and reloading the module does NOT help
        • Restarting sys-net DOES helps
        • After some experiments I found a workaround:
          • Force unload/reload of module r8169 upon suspend → add r8169 to /rw/config/suspend-module-blacklist
          • Disable D3cold → /rw/config/rc.local writes 0 into /sys/class/net/ens…/device/d3cold_allowed
        • → Ethernet is now usable after resume
        • I am NO expert on these hardware-level issues, so I’d be thankful for feedback if this is a bad idea!

4. Not (yet) tested:

  • Fan control / CPU power management
    (You can hear the fans permanently, but it’s definitely more of the “soft background breeze” quality, not “ready for takeoff”)
  • TPM / Trusted Boot
  • Thunderbolt

5. HCL report card:

---
layout:
  'hcl'
type:
  'Notebook'
hvm:
  'yes'
iommu:
  'yes'
slat:
  'yes'
tpm:
  '2.0'
remap:
  'yes'
brand: |
  TUXEDO
model: |
  TUXEDO InfinityBook S Gen8
bios: |
  1.07.10RTR1
cpu: |
  13th Gen Intel(R) Core(TM) i7-1360P
cpu-short: |
  FIXME
chipset: |
  Intel Corporation Raptor Lake-P/U 4p+8e cores Host Bridge/DRAM Controller [8086:a707]
chipset-short: |
  FIXME
gpu: |
  Intel Corporation Raptor Lake-P [Iris Xe Graphics] [8086:a7a0] (rev 04) (prog-if 00 [VGA controller])
gpu-short: |
  FIXME
network: |
  Intel Corporation Raptor Lake PCH CNVi WiFi [8086:51f1] (rev 01)
  Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
memory: |
  32471
scsi: |

usb: |
  3
certified:
  'no'
versions:
  - works:
      'FIXME:yes|no|partial'
    qubes: |
      R4.2.1
    xen: |
      4.17.4
    kernel: |
      6.9.2-1
    remark: |
      FIXME
    credit: |
      FIXAUTHOR
    link: |
      FIXLINK