HCL - Lenovo ThinkPad E14 Gen 4 (AMD)

---
layout:
  'hcl'
type:
  'notebook'
hvm:
  'yes'
iommu:
  'yes'
slat:
  'yes'
tpm:
  'unknown'
remap:
  'yes'
brand: |
  LENOVO
model: |
  21EBCTO1WW
bios: |
  R20ET26W (1.06 )
cpu: |
  AMD Ryzen 7 5825U with Radeon Graphics
cpu-short: |
  FIXME
chipset: |
  Advanced Micro Devices, Inc. [AMD] Renoir Root Complex [1022:1630]
chipset-short: |
  FIXME
gpu: |
  Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:15e7] (rev c1) (prog-if 00 [VGA controller])
gpu-short: |
  FIXME
network: |
  Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
  MEDIATEK Corp. Device 7961
memory: |
  6990
scsi: |

usb: |
  2
versions:

- works:
    'FIXME:yes|no|partial'
  qubes: |
    R4.1
  xen: |
    4.14.5
  kernel: |
    5.15.52-1
  remark: |
    FIXME
  credit: |
    FIXAUTHOR
  link: |
    FIXLINK

---

Remarks

I have chosen the MediaTek 7921 Wireless LAN adapter during customization. (The other option is Realtek 8852BE.)

Only soldered 8 GB RAM is implemented. I will add a discrete RAM some day.

The 4.1.0 installer does not display the wizard, probably due to the graphic driver. The 4.1.1 installer works.

  • Installation: Hanged at network configuration during the post-installation wizard (Manual power-cycling let the wizard finished.)
  • Graphics: Internal monitor tested and worked
  • Networking: Wireless LAN tested and worked
  • Audio: YouTube with Firefox tested and worked
  • Suspend: Stuck with blank screen, with or without the mem_sleep_default=deep kernel option

Feel free to ask me anything!

Attachments

Qubes-HCL-LENOVO-21EBCTO1WW-20220722-200409.yml (848 Bytes)

Qubes-HCL-LENOVO-21EBCTO1WW-20220722-200729.cpiogz (9.9 KB)

1 Like

It does not occur when I reinstalled Qubes from scratch. Never mind.

1 Like

Thank you @omasanori for your HCL report. Sorry it took so long, but it is now listed in the HCL.