HCL - Lenovo Ideapad 3 (15") 82H8 - i5-1135G7 + XE Graphics

HCL Report

brand: |
model: |
bios: |
cpu: |
  11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz
cpu-short: |
chipset: |
  00.0 Host bridge [0600]: Intel Corporation 11th Gen Core Processor Host Bridge/DRAM Registers [8086:9a14] (rev 01)
chipset-short: |
gpu: |
  02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] [8086:9a49] (rev 01) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)
memory: |
scsi: |
usb: |
- works:
  qubes: |
  xen: |
  kernel: |
  remark: |
    See Post.
  credit: |
  link: |



I have been wrestling with this on-and-off for the past year and a half. This cannot be done without replacing the SSD. My Optiplex with no SSD was able to install it on the first try, so do consider getting more “dedicated” hardware if possible or defer to ProxMox if security isn’t a concern, as you can likely get a refurbished Optiplex for the equivalent price of the SSD you’d buy to do this.


  • Disable secure boot
  • I burned the image on an old USB 32GB USB drive while booted into an Ubuntu Live CD
  • Disabling hyperthreading didn’t seem to fix any of my issues
  • Cannot be done with the stock UMIS AM620 (“Union Memory”) 512GB SSD
    • Installation completely hangs. Instead, I replaced it with a wiped Samsung 960 Pro (512GB) and installed 4.1.1 using the default LVM partitioning. The 4.2.0rc doesn’t even show an installation screen.
    • Both the UMIS SSD and the 960 will successfully install Qubes if there is no other SSD in the system and the SSD is in an external enclosure (I used a Sabrent USB NVMe). The second I add the other SSD (even if completely wiped), it breaks boot, the progress bar takes forever to finish, and instead I get booted into emergency mode. I gave up after staring at the GRUB screen for hours trying to correlate device IDs and playing around with Refind/GParted.

Confirmed Working

(Note, I am very new to this and haven’t tested everything)

  • Rebooting (very relieving)
  • WiFi (was able to pull 300mbps on my Bell Canada Giga Hub 1.5gbps connection; my iPhone 14 Pro Max for reference pulls 500mbps)
  • Mouse (both trackpad and external USB Razer Naga)
  • Keyboard (both built-in and an external USB keyboard)
  • Function keys (but not FN-function keys like brightness, volume)
  • Numpad (including num-lock and numpad arrow keys)
  • Booting from other unrelated devices (I have an external M.2 SSD enclosure with ProxMox; I am able to boot from it and not affect the other partitions holding Qubes’ EFI. Kind of implied, but I’ve had so many issues installing this OS on an NVMe I was at one point convinced that booting from a USB would break everything)
  • Display output - no tearing or issues watching YouTube
  • Updated Whonix and Fedora using the built in updater, though it took a bit

Not Working ATM

  • Wake from suspend (I have not tried adding mem_sleep_default=deep to the GRUB config yet). The screen goes black and the power LED starts blinking. No keyboard input or push of the power button will wake my sleeping beauty of a laptop. The screensaver causes no issues, though.
  • Speaker output (need to install SOF drivers maybe)

Haven’t Tried

  • Audio over 3.5mm jack
  • HDMI/external displays
  • Bluetooth
  • Webcam
  • Microphone
  • Ethernet


The report is pasted above.

1 Like

Thanks for submitting this HCL report. I just created a pull request to add it to the database.



1 Like