Having some issues with freshly installed Qubes


I’ve installed Qubes and updated it successfully with Qubes Updater(updated only dom0), but I keep getting some bug: when I press restart or shut down computer hangs out on black screen and I must shut it down with a physical button. I found out it was a known issue here: https://github.com/QubesOS/qubes-issues/issues/1581 , but over here linux - How to safely shutdown every running VM during Restart/Shutdown in Qubes OS 4.0 without incurring a stall/delay due to a timeout? (systemd issue) - Unix & Linux Stack Exchange it says the issue got fixed. So I’m really not sure what to do with this. This is very, very much annoying.

Another issue is with installing KDE. I tired the official way, as docs say:

sudo qubes-dom0-update @kde-desktop-qubes

but it failed at the first try. I then ran into google and found that I’ve should use

sudo dnf install apper breeze-icon-theme colord-kde dolphin kcm_systemd kde-runtime kde-settings-pulseaudio kde-style-breeze kdelibs kdeplasma-addons kdialog khelpcenter khotkeys kinfocenter kmenuedit kmix konsole5 kscreen ksysguard kwin phonon-qt5-backend-gstreamer plasma-breeze plasma-desktop plasma-desktop-doc plasma-pa plasma-user-manager plasma-workspace polkit-kde qt5-qdbusviewer sddm sddm-breeze sddm-kcm sni-qt

I tried that and it installed some 300MB successfully just to find out that I’ve should use something else(below) instead and the previous method of installing lots of packages with dnf on dom0 is a big mistake.

sudo qubes-dom0-update kde-settings-qubes 

So I did run this command and it successfully finished, but I don’t get any visual changes. Do I need to do something else?

P.S. I re-installed the entire system and updated the dom0.

The long winded way isn’t a big mistake, it’s just long winded, and error

(Install sddm for better login experience)
Log out, select KDE at login screen.

@unman I agree with the statement and thank you for support.

I did as you suggest and it worked. I must say though, I switched from Manjaro and the KDE experience is very different. I feel that something is different, but don’t know what exactly. For example, when I click on the network icon(it’s blank icon now, after switching to KDE) in the system-tray it open a pop-up with networks available, but it’s very glitchy to close it. I close outside of the window and it doesn’t work, I click on the same icon and sometimes it works sometimes not.

And the reboot/shutting down black screen is present and I have no idea how to deal with it.

do you have discrete graphic on your laptop? try use discrete only and see if the problem persist.

In my machine only reboot is affected, it’ll never reboot just black screen. If power off also affected, you should sent an hcl.

Not at all, I have embedded intel graphics.

Yes, both, reboot and powering off. As far as I get it, the HCL is only for future possible fixes, is it not?

what the default template for your sys-? and what kernel you use? mind to share what laptop / pc you use?

HCL is Hardware Compatible List

That (un)icon can be difficult - usually a Rclick can close - at worst I
VPN–Connections → Add, and close that window. Not often .
I don’t have any experience outside Qubes to make a comparison.
Interested to hear your thoughts.

@51lieal You know what, I’m pretty sure I had like at least twice getting black screen while powering off(not rebooting), but after something(or switching to KDE, or updating) I have only on reboot as well. That’s less painful.



Yes, of course: XPS 13 9380 with i7 8565u

Yes, but I thought you were talking about sending HCL report via email, as stated here: How to use the hardware compatibility list (HCL) | Qubes OS , correct? It says “report for the benefit of further Qubes development”, so I doubt there will be any solution in the nearest future, unfortunately. But I don’t mind to shoot the email if that’s gonna help the team.


What is (un)icon? Is it different from everything else in someway? Is it customizable(I have just blank white square)?