Having difficulties setting up VPN in 4.1RC2

I’m unable to set up VPN. I tried the ProtonVPN client and it installs and connects but VM’s can’t use it, and it also doesn’t persist across reboots. I tried to install the qubes-tunnel script but it’s not in qubes-repo-contrib. I was able to restore from backup a 4.0 VM with VPN which works for some reason, but when I tried to clone it I couldn’t get it to work.
There doesn’t seem to be any normal way to set up a VPN proxy.
EDIT: I tried to run ProtonVPN in the VM sys-vpn and it seems to work, but the connection doesn’t start automatically on startup. I’m also only able to ping IP’s, but not resolve DNS’s…

1 Like

Have you tried GitHub - tasket/Qubes-vpn-support: VPN configuration in Qubes OS


It seems to be working now. I don’t know understand what I did now that it worked. Thanks!
If I’ll clone it and run the script again it’ll create another connection?
EDIT: looks like cloning works.
This was a lot of work. I wish it came preconfigured in the sys-vpn VM (what’s it even for?).

There’s no pre-configured sys-vpn VM.