Have to attach / de-attach / attach USB SSD

This has been consistent behavior for me since from day 1. Using the latest public release, KDE, Installed qubes with a PS2 Mouse and keyboard. in order for a USB drive to show up in the nautilus folder i have to attach. de-attach, then re-attach. I can then see the drive. Anyone else observe this behavior?

I’m assuming that “latest public release” is 4.0
You haven’t said where you hope to see the drive - I mean, in which
What template are you using for sys-usb? Have you tried with a different

I don’t see this behaviour.

Im using the qubes 4.04. Attaching to a debian qube labeled backup. It doesnt seem to matter which cube I attach to. sys-usb is fedora - ill change that to debian to see what happens. Thanks for the pointer unman. I’ll report back.

Update: ok switched sys-usb to debian. Same behavior. I open certain qubes on boot. One is called “work”. it opens thunderbird, chromium and Nautilus.

The other is Finance that opens Keepass and Chromium.

When I tried attaching to work - i had to de-attach and re-attach. I then attached to finance, then opened nautilus and the drive was there.

Hmmm - It may be that if Nautilus is already open then the drive doesn’t attach. But if I attach and then open Nautilus it does appear.