GUI glitches (GUI troubleshooting dont work)


Im new to Qubes and im fascinated with all the possibilities it offers.
I haven’t had time to read as much as i would have liked, so I apologize if my questions have already been answered alsewhere.

Im having this problem with GUI: GUI troubleshooting | Qubes OS

I disabled the window compositor but still having problems.
It doesn’t scale as much as when it was activated that it got to the point of having to unplug. But it is still makes it almost impossible to work.

Right after start everything looks fine, but when i start running multiple qubes, black boxes starts to appear over fonts and buttons and it just get worse.

I have tried GUI troubleshooting 1 and 2 (cause i have 2 displays) whit no results.

i have 16gb RAM running at 3200 with Xtreme Memory Profile cause whitout it my motherboard just reach 2133.
I have AMD-V on and a Radeon graphics card.
Since i have fallen in love with qubes im thinking on duplicate my ram, but i dont really know if having more than 16gb will help with the issues I am facing.

Which AMD CPU / Motherboard do you use? Did you try the latest kernel (kernel-latest package in dom0)? Is everything upgraded?

Ryzen 5 2600x on an Aorus B450.

I dont know if I have the latest kernel, on global settings it appears as [ 5.15.63-1.fc32 (current)] and the 2 other options are an old one and none, so i guess yes?

Its a fresh installation made this week, right after install i enable uptades whitout known availables and updated all, i experienced some problems doing this but i think nothing important to be mentioned, as in previous testing installations i had the same issue with black boxes and weird glitches.

First, try to see if dom0 need updates (just in case) by doing this in a dom0 terminal: sudo qubes-dom0-update

Then, install the kernel-latest package with the following command (in the same dom0 terminal): sudo qubes-dom0-update kernel-latest kernel-latest-qubes-vm (it will install latest kernel available today → 5.19.6)

Once done reboot your system, make sure you run on it and see if your issue is fixed.

If it’s still not working, can you precise your GPU?

1 Like

I think my dom0 is updated, cause as i said, i clicked on the box "enable updates for qubes without known available updates" and selected all qubes, including dom0. After a couple of attempts, all qubes showed a green tick. As if this were not enough, also use the Qube Manager to try to update all the templates and dom0 from there, so i think dom0 must be well updated :sweat_smile:

Regarding the command u post for update: sudo qubes-dom0-update i dont know if you have only had a small mistake or u are really asking me to run this command, but I preferred not to do so cause here How to update says Warning: Updating with direct commands such as qubes-dom0-update, dnf update, and apt update is not recommended

Regarding the other command for the kernel, I have not tested it since the first one was found to be “unsafe”, i preferred to wait.

Anyway, thank you very much for your help, and i hope you can understand my mistrust, since we are talking about a security focused OS :wink:

This warning doesn’t include installing packages but only updating them, you can do it but if you want to you can use qubesctl or the Qubes Update Tool. Anyway, you’ll need to do sudo qubes-dom0-update <package> to install the needed packages in dom0.

No issue, I understand no worries!

1 Like

Okey, thanks, now i understand everything.

And is there any security risk in installing the latest kernel? For now i think i will wait in case someone says anything else, since its not certain that this will solve my problem, is it?
If nobody suggest another solution I will try it, although I didnt want to make such important changes until i can fully understand what Im doing cause I suppose there are reasons why that kernel comes by default.

Installing the latest kernel is not giving any security issue. It’s built by Qubes OS (ex: Pipeline · QubesOS / qubes-linux-kernel · GitLab) so you have nothing to worry about. The kernel that comes with Qubes by default is 5.15 (LTS), but in some cases some hardware needs upstream changes that aren’t in 5.15 (yet), running the latest kernel can fix a lot of issues.

1 Like

Still not working… maybe not as bad as before but still glitching.

My gpu is a radeon 5500xt, it has a dual bios button to switch between default bios an a silent one, as soon as i can, I will try to switch it to see if thats the problem although i dont think so.

I’ve noticed that this starts to happen when i start running several qubes at the same time, and especially when i play multimedia in one of them such as youtube.

i’ve done sudo qubes-dom0-update kernel-latest kernel-latest-qubes-vm but the kernel i have now is 5.18.16 instead

Latest kernel is available in the testing repository it seems. In dom0, try this: sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest kernel-latest-qubes-vm

Also, not sure if it can helps, but try to install xorg-x11-drv-amdgpu in dom0 and see if it makes any difference.

wanted to check out my rx 580 that package cannot be found in my 4.1 dom0, i see though a