Grub bootloader doesn't show up

i set my bios settings back to default and since then, i can’t see the grub bootloader anymore.
what i’ve tried so far:
booted into the qubes-os troubleshooting grub option on the installer usb.
efibootmgr -v -c -u -L "Qubes" -l /EFI/efi/grubx64.efi -d /dev/myefidrivesomethingwithnvme0np1 -p 1
^this didn’t make any changes
then i did a mkdir mydrive in /mnt/ and mounted my nvme0n1p1
i saw in /EFI/ are 3 dirs:
BOOT (which is empty)
and qubes
i tried to copy all files from qubes to BOOT but didn’t helped
then i tried:
grub2-install --installation-directory=/mnt/mydrive
^since then, i’m booting into grub rescue what doesn’t bring me further.

guess that’s all i tried now.
i would be glad if we could fix it.

i’ll edit this thread with my solution as soon i got one


you said you set your bios back to default, did you check UEFI boot was still allowed on it and not restricted to “legacy mode”?

i can’t set it to legacy or uefi, i already checked if it’s a problem with this.
i got a lenovo p15v, seems like uefi is standard here.

Just to make sure, /dev/myefidrivesomethingwithnvme0np1 should be /dev/nvme0n1 without specifying partition e.g. not /dev/nvme0n1p1 since the partition is specified by -p 1 option.
And you should’ve used /EFI/qubes/grubx64.efi instead of /EFI/efi/grubx64.efi.

Did you change filenames grubx64.efi → BOOTX64.efi and grub.cfg → BOOTX64.cfg after you copied files from EFI/qubes to EFI/BOOT?

tried both of your tips now, i also see everytime new entries from the qubes label, but none of them are opening the qubes grub menu

Did you only try to boot using Qubes entries? The files in EFI/BOOT will be used when you try to boot using the entry for your Qubes drive.

no i tried to boot with the qubes boot entries and the nvme names.
if i choose the qubes entries my screen is going to be black shortly and then i’m getting redirected to the boot list.
if i’m choosing a nvme to boot from i’ll end up in the grub rescue mode.

Maybe you’ve overwritten your Qubes grub files with empty ones after you run:
grub2-install --installation-directory=/mnt/mydrive
What is the content of EFI/BOOT/BOOTX64.cfg?

nope, i already looked up, the BOOTX64.cfg got contens in it
the grub2-install just created another folder between BOOT and qubes which were called grub
it only contained 1 file… i guess grubx64.efi
but i already deleted the folder because it only bring me to grub rescue
anyhow… i’m getting in it still

Maybe there’s an error in grub config file. But if you’ve only changed BIOS settings and didn’t touch the grub (manually or because of dom0 update) on your last successful Qubes boot then there should be no changes to it.
I can suggest to try and manually boot Qubes from grub rescue and see if there will be any errors:
In grub rescure type:
configfile (hd
press tab to see the list of partitions that GRUB knows about
You can try each in the list and look for the /efi/qubes/grub.cfg or /efi/boot/bootx64.cfg file on them.
And try to boot with the command, for example:
configfile (hd0,gpt1)/efi/boot/bootx64.cfg

ok, i found someone with who i was able to fix the problem that i didn’t saw the gpt partitions and we did the grub2-makeconfig -o,…
my problem remaining is, that i’m still booting into grub bash.
if i want to get the qubes grub menu, i have to run the configfile command you provided.

is there a way to make this setting permanent?

Which EFI entry do you use to boot Qubes?
Which config file do you use in grub rescue?
configfile (hd0,gpt1)/efi/boot/bootx64.cfg
configfile (hd0,gpt1)/efi/qubes/grub.cfg
Maybe you try to boot using default boot path /EFI/BOOT/BOOTX64.EFI by selecting to boot your Qubes drive EFI entry but it’s configuration file /EFI/BOOT/BOOTX64.CFG contains an error so it fails but when you use another config file /efi/qubes/grub.cfg it works?

oh im not anymore in grub rescue im now in grub bash, if i want to get into the grub menu i have to type configfile (hd0,gpt1)/efi/qubes.cfg or /efi/boot/bootx64.cfg - either work.

but idk sadly which efi entry i’m using, never messed around with efi or grub.

Do you mean dracut emergency shell? If you’re in the shell then you’ll need to look for errors in logs to see what’s failing.

Everyone: total n00b with Qubes here but… I installed it on an old Core i7 2600k system on an x58 chipset. Installation went ok from USB (it won’t install from a ventoy installation key for some reason). Went to boot and grub couldn’t find hd0, etc. etc.
To resolve - I went to BOIS and switched the drives back from ACHI to IDE mode. Instantly the OS worked and is operating now.
I"m not sure if this of help to anyone here or if my problem just looks similar to others posted here but it may help someone get running on older kit like mine.

I encountered exactly the same problem (with the additional problem that my disk is encrypted, so I can’t load kernel image that is encrypted).

In UEFI bios options, one could select Add a Bios Option. That opens up all available drives in the computer. For each drive, it will find the system partition and shows available files. I essentially have two relevant files: grub.cfg and grubx86.efi. I selected both and each time defined a new boot option. I always end up with grub shell. My system partition has a EFI folder that contains just a few config files. The kernel images are encrypted, and not there,

Has a solution to this issue been found?

I explained the my issue at end of the comments in this thread: