Gnome-terminal doesn't work with debian 11 minimal

I noticed gnome-terminal doesn’t work with debian 11 minimal. It works with debian 10 minimal. All the related packages appear to be there. Debian -- Details of package gnome-terminal in bullseye

Any idea what’s the issue?

It works with debian-11 minimal also - what makes you think it doesn’t?
(I’m tempted to say that a minimal template is no place to install
a hog like gnome-terminal, but horses for courses.)

After cloning a minimal I simply install it apt install gnome-terminal. I don’t know. It works for me in 10 but not 11, following the same steps. Restart the qube and I click on the shortcut and nothing happens. Sometimes I remove the shortcut, save, close. Then, add it back, save, close, run shortcut and nothing happens. I can live with xterm. Gnome integrates better that’s all. Just preference.

I tested like this: cloned the 11-minimal template, installed gnome-terminal, added the
menu item to the displayed menu for a qube, and everything worked as expected.
What shortcut are you talking of?
If you run xterm, can you run gnome-terminal from there?
Finally, are you on 4.0 or 4.1, using Xfce, KDE, or something else?

I’m on R4.0.4 Xfce. I used the “Terminal” shortcut it creates. I should correct myself from, nothing happens, to the qube starts in a green state, then nothing happens from the shortcut. From xterm it displays:

#Locale not supported by C library.
#Using the fallback ‘C’ locale.
#Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0:
Error calling StartServiceByName for org.gnome.Terminal: Process org.gnome.Terminal exited with status 9

I fixed it by updating the templatevm by entering localedef -f UTF-8 -i en_US en_US.UTF-8