Global clipboard doesn't seem to work


I’m trying to use the global clipboard,
pressing Ctrl+C, Ctrl+Shift+C, Ctrl+Shift+V, and Ctrl+V.

It seems like I’m supposed to get a message saying that n bytes were copied, but I never got any of those, and the paste shortcut does nothing on target qube.

How can I try to fix this issue?

I’ve tried changing the keyboard layout, and performed a complete reboot.

Instead of Ctrl+Shift+C, try pressing Ctrl+WIN+C.

You can change this behavior in the Qubes Global Settings.

Tried Ctrl+Alt+C and Ctrl+Win+C, doesn’t seem to do the trick.

The system tray says that the global clipboard is still empty.


Check the Qubes Global Settings for the correct combination for your system.

Just in case.

I’ve checked the global settings, they seem to be
Copy (inter-qube): default (Ctrl+Shift+C) (current)
Paste (inter-qube): default (Ctrl+Shift+V) (current).

What’s the status of the qubes-qrexec-policy-daemon service?

Check with systemctl status qubes-qrexec-policy-daemon

1 Like

I’ve fixed the issue:

It seems like the system default keybind for Change layout was set to Ctrl+Shift, which was intercepting the keybind.


You’ve given very little information. Since the global clipboard
does work, we are forced to conclude that there is something specific
on your set up that is causing the problem.

Where were you trying to copy from?
What templates are you using in the source and target qubes?
Have you made any significant changes since installing Qubes?
Did copy/paste between qubes ever work?
What keyboard layout were you using?
What is your actual keyboard layout?
What have you changed the keyboard layout to?