Gigabyte x570 Gaming X motherboard


UEFI mode doesn’t work on default settings, Installation workaround needed (Do not create sys-usb on first config, do it manually attaching one of usb-controllers in permissive mode, described in Qubes Docs). Integrated Graphics and TPM not tested (but present).


Qubes-HCL-Gigabyte_Technology_Co___Ltd_-X570_GAMING_X-20201112-210824.yml (1.2 KB)


To be easier to solve mentioned sys-usb problem, here is exactly part of documentation you need :slight_smile:

Are you still happy with your system and the compatibility with Qubes?
I’m currently trying to find a good Qubes-compatible AMD system to buy and was considering your setup.

Sorry for long absence, I was reeealy busy :wink:

Yes, I’m really happy with this configuration as it will probably have future support for new processors series. It’s easy extensible, painless (e.g. no nvidia), maybe not the best for now but in reasonable price. That’s also why I chose it.

If you are audiophile only bad thing is DAC. I could hear difference comparing to just hifiberry! so yeah… If you’re going to listen music in good quality you should buy external DAC.

Well, there are no problems without workaround as mentioned above. I couldn’t boot it in UEFI mode (so just changed to BIOS) and sys-usb needs to be created after install as not supporting PCI reset breaks installation if you do it automatically before first access to qubes.

Another good thing is speed. OS Booting up is slightly faster than e.g my TP500LAB

But the best thing is appVM boot time. It’s only 6 seconds! (Comparing to TP500LAB 10-20, I don’t remember precisely) then app in appVM starts immediately.
(I have m2 disk 32 gigs of ram and ryzen 7 3800x)

Have you ever tried Qubes before or do you know its construction (appVM etc.)? If not I’ll try to explain it more precisely.

If you have any questions, just mark me somehow, so I’ll get notification. :wink:

Epic! If you have the chance, add this result to this table where we’re collecting VM boot times:

How did you measure?

I do this:

[user@dom0] date -R && qvm-run --pass-io personal-web “date -R”
Sun, 27 Jun 2021 16:57:21 -0500
Sun, 27 Jun 2021 16:57:29 -0500

I tried with several different qubes and get reliably 8 seconds on a
ThinkPad T430 with i7-3840.

I’ll try in meantime :slight_smile:

Firstly I just counted… But your command output tells me same:
(Tested on fedora-33 appVMs)

[<user>@dom0] date -R && qvm-run --pass-io <my-secret-qube-name> “date -R”
Fri, 30 Jul 2021 19:33:33 +0200
Fir, 30 Jul 2021 19.33.39 +0200

After shutdown I retested a bit later using same command

[<user>@dom0] date -R && qvm-run --pass-io <my-secret-qube-name> “date -R”
Fri, 30 Jul 2021 19:41:57 +0200
Fir, 30 Jul 2021 19.42.02 +0200

Then I picked another qube

[<user>@dom0] date -R && qvm-run --pass-io <my-second-secret-qube-name> “date -R”
Fri, 30 Jul 2021 19:42:58 +0200
Fir, 30 Jul 2021 19.43.05 +0200

Then shutdown and start again:

[<user>@dom0] date -R && qvm-run --pass-io <my-second-secret-qube-name> “date -R”
Fri, 30 Jul 2021 19:43:25 +0200
Fir, 30 Jul 2021 19.43.31 +0200

Average is 6 sec.

I’ll do precise tests later.

TBH I’ve bought parts thinking about qubes and future with small risk of incompatibility as vendor docs weren’t enough exhaustive.

My first HCL report probably contains other ssd than I use because I’ve changed hardware (added RAM - same model, ssd is now m2 WD black) I’ll regenerate it later with speedtest.

1 Like

Thanks for the report. I’m new to Qubes (never used it) and deciding on what pieces to use for my next rig. Would you please add more details to the following?

I couldn’t find any article detailing this limitation in the Qubes documentation. In any case, is this an option provided by the motherboard itself? Also, is BIOS necessary to boot the first time (i.e. for Qubes installation) only or is it required every single time I want to use Qubes?

Does that mean I need a PS2 mouse + keyboard? (I can’t find PS2 inputs in the X570 specs.) In other words, will a regular USB (wired) mouse and keyboard not work out of the box?

I don’t have any CDs/DVDs etc. – I only listen to MP3, WAV files etc. (all inside the machine itself). Do I still need a DAC?

Given that you seem to be in a conversation with BBro & BBro may yet respond, sorry to intrude but I checked. Looking around (not advertising in any way for the company or it’s products but helping to spot check something that others might have missed) there is the original X570 Gaming X motherboard (2 PS/2) & the newer X570S Gaming X motherboard (1 PS/2). Note the S in the name, not certain whether the OP has the original motherboard. Either could work without requiring a USB keyboard (or even a USB mouse), theoretically.

1 Like

This looks great @BBro!

I have two questions:

  1. Does Qubes work with the onboard HDMI, or is the Radeon 100% necessary?
  2. The board looks like it can handle the Ryzen 5000 series, does this mean I would be able to use a 12-Core Zen3 - or will Qubes only be able to use this specific 3800X processor? (i.e., can I use any Ryzen CPU that the X570 board supports with Qubes?)

Thanks in advance.

Sorry for no response. I’m reeeeeeeeeeally busy and misfortunately deleted my qubes installation while playing with another linux on same machine: If you know how, please help me… [Help needed] Recover deleted partition table

Answering your questions:

You need to tweak settings before you try to boot Qubes installer
First of all, enable IOMMU and virtualization (SVM Mode)
Then check if your settings allows to boot in “legacy mode” or “CSM mode”
Lastly, restart and enter boot menu using f12 key and choose your USB installer (without “UEFI:” Prefix)

Thanks for explanation :slight_smile: and sorry for mess.
I have motherboard rev 1.1 with separated PS2 keyboard and mouse so 2 PS2

When I was installing qubes, there was no option to set permissive mode easily through installation. So i just used ps2 keyboard and mouse, when installation completed I created sys-usb and set pass-through usb keyboard and mouse.

No you don’t. However I have to admit, that yesterday, while replacing my graphics card I might have broken onboard audio, as it now produces only silence… (don’t know even how, so be careful) - it shows in the menu, but I hear nothing in my headphones.
It’s just offensive assumption but its “mechanical” quality also seems not be good…

  1. I’m not expert but it depends on that if processor has graphics processor included, that’s how works integrated graphics. My ryzen 7 3800x doesn’t have one so I bought some old cheap non-NVIDIA graphics card that had quite good linux support in the past.
    You may ask how do you check it: For instance, I searched for “ryzen 7 3800x integrated graphics” and found this site: AMD Ryzen 7 3800X Specs | TechPowerUp CPU Database
    In the integrated graphics section there’s N/A.
    Do the same with your specific processor model.

  2. Like above I’m not sure, First of all, check BIOS updates on official website, there are plenty of them and they bring support for newer processors.
    But This series seems to be quite new so there might some problems. First of all, check for general support for desired series in connection with linux kernel. Then compare mentioned kernel version there to that qubes uses.

Once again sorry for being idle. Hope it helps. If something is not clear, write here :slight_smile: