Geoclue Demo agent

In ‘Session and Startup’ ($ xfce4-session-settings),
the Geoclue Demo agent is ticked by default. What is
this for? It does not appear in Qubes Community search
or in Mail Archive search.

1 Like

I assume you are talking about Home · Wiki · geoclue / geoclue · GitLab

Where is it enabled by default, it’s not enabled in dom0 on my system?

Applications - System Tools - Session and Startup - Application

from terminal $ xfce4-session-settings

It’s not installed on my system.

Does it show up in ‘dnf history userinstalled’ ?

No, not installes by me. According to Home · Wiki · geoclue / geoclue · GitLab

"Geoclue is a D-Bus service that provides location information. The goal of the Geoclue project is to make creating location-aware applications as simple as possible.

The aim of project is to utilize all possible sources of geolocation to best find user’s location:

  • WiFi-based geolocation (accuracy: in meters)
  • GPS(A) receivers (accuracy: in centimeters)
  • GPS of other devices on the local network, e.g smartphones (accuracy: in centimeters)
  • 3G modems (accuracy: in kilometers, unless modem has GPS)
  • GeoIP (accuracy: city-level)"
    and on {Solved] Geoclue demo agent - Linux Mint Forums
    " package geoclue-2.0 which is a service that facilitates location aware applications to get your location. I think it’s probably preinstalled in Mint XFCE as a dependency of redshift."

I had tried to install redshift awhile back but did not succeed -
perhaps this is a remnant, though it was never intentionally

Installing redshift is coinstalling geoclue2 indeed. Geoclue2 ate my RAM on a former used OS and that had been an issue for more than 2 years according to google findings.

I saw somebody report the issue on geoclue’s gitlab repository and it took the maintainer more than 6 month to respond. At that point I already had manually removed the binary and masked the service file.

There are downsides to FOSS of course and I understand that some maintainer don’t have time to maintain their software. However, I would expect redhat or ubuntu to remove right-in-the-eye-faulty software from their repositories without further notice.

I have redshift manually installed in dom0, but no sign of Geoclue on my system.

[root@dom0 user]# qubes-dom0-update --action=install redshift
Using sys-net as UpdateVM to download updates for Dom0; this may take some time...
Qubes OS Repository for Dom0                                              2.9 MB/s | 3.0 kB     00:00    
Qubes OS Repository for Dom0                                              185 kB/s | 1.6 kB     00:00    
Dependencies resolved.
 Package               Architecture        Version                   Repository                      Size
 redshift              x86_64              1.12-7.fc32               qubes-dom0-cached              155 k

Transaction Summary
Install  1 Package

Total size: 155 k
Installed size: 568 k
Is this ok [y/N]: N
Operation aborted.

Geoclue is obviously not coinstalled with redshift on Qubes OS.

interestingly, when I check dnf list installed geo* on my Qubes 4.0 machine it does list geoclue2.x86_64 ... @anaconda. However, it is not installed on my Qubes 4.1 machine. Both machines have Redshift installed.

The build for the Fedora 1.12-7 seems to include geoclue2-dev

BuildRequires: geoclue2-devel

Using sudo dnf list installed geo*, and then sudo dnf remove geoclue2*.* I could remove geoclue from all the fedora templates, services,and qubes.
Using sudo apt list installed geo* showed geoclue2 in all debian templates and qubes, but using sudo apt remove geoclue2*.* did not remove any of them, but gave error ‘unable to locate’. sudo apt list shows them installed - sudo apt remove says unable to locate. sudo apt autoremove no effect also.

Try the following command, which will only show the installed packages, not the available packages::

sudo apt list --installed | grep geoclue

I assume you realised your mistake in installing it in to the templates
and qubes. You only need redshift in dom0. (If you use another guiVM then
you will need it installed in that qube, (and so in the template).

The package in Debian is geoclue-2.0: it is a recommend of redshift on
Debian, not a requirement.
apt list --installed geoclue* will show if it is installed.
If it is, apt remove geoclue-2* will remove.

All instances of debian and whonix now show geoclue not installed - thank you ephile!

I was under the assumption that I should not install anything in dom0 - mea culpa.