Garbled audio on Whonix but not Fedora via PCI

Over the years I’ve had sound issues with qubes off and on. For a while it’s been going well until a recent update. My set up is using Whonix Workstation template to send sound via an attached PCI device to my audio output. As the title says, the audio has been garbled for the last couple weeks or so.

I just tried switching the template to Fedora-39 and sound is good. Also note that sound through HDMI from any qube seems to be good.

I still don’t know much about the different audio software. I know Pipewire was added in the recent past.

Any suggestions on tracking down what is different in Fedora vs. Whonix that is causing the different audio quality?

Tried increasing RAM and CPUs - no effect.

Tor Browser, VLC, Quod Libet - all have similar audio noise.

Going through HDMI as HVM or PVH sounds ok (not great), but doesn’t work as a solution for various reasons.

Going through PCI audio seems to be the variable causing the problem.

[EDIT: forgot the OS variable as well. Sound issues on Whonix and Debian, sounds fine in Fedora-39. Still have no idea how audio is different between them.]

I wanted to try audio settings. Silly question - how to open audio settings in Whonix? In Debian I have Settings, System Settings, etc. But in Whonix list of Applications in Qubes Settings there are no such thing?

I would try a different Kernel version.

You need to install pipewire-pulse in Whonix-workstation template and restart anon-whonix. After that it should work normally. Here it did.


Seems that’s already installed, thanks though.

Right, hadn’t tried that yet.
Now I’ve tried whonix kernels:


If anything the oldest one is worse, but none of them work well.

May I ask the model and manufacturer of the PCI Audio Interface? It does not have fancy features such as DSP?

Don’t think it’s fancy. I believe it is:

Asus Sound Card MIO Audio 892

But shows up as Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) in Qubes Settings

1 Like

Using VLC, and setting template as Fedora-39, Audio Device defaults to:

Default ALSA Output (currently Pipewire media server)

and it throws errors that there is no audio available. Same errors if I set Audio Device to:

PipeWire Sound Server

Audio works good when I set to 3rd option:

HDA ATI SB: ALC892 Analog Default Audio Device

Seems to indicate Fedora is not using PipeWire when it works?

I tried:

qubes-dom0-update --switch-audio-server-to=pulseaudio

and back to:

qubes-dom0-update --switch-audio-server-to=pipewire

I restarted the whonix AppVM after each one and then tried playing music.
I do think there is an improvement in the sound now with pipewire overall. But they both have the same garbled/skipping audio effect in Whonix still.

1 Like