Gajim Issue on Qubes 4.2.0-rc5 (R4.2)

OS: Linux 6.1.62-1.qubes.fc37.x86_64
GTK Version: 3.24.38
PyGObject Version: 3.42.2
GLib Version : 2.74.4
python-nbxmpp Version: 4.2.2
Gajim Version: 1.7.3

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 387, in _handle_local_options
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 272, in _startup
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 105, in __init__
    self._main_stack = MainStack()
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 42, in __init__
    self._chat_page = ChatPage()
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 62, in __init__
    self._chat_stack = ChatStack()
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 74, in __init__
    self.add_named(ChatPlaceholderBox(), 'empty')
  File "/usr/lib/python3/dist-packages/gajim/gtk/", line 830, in __init__
    pixbuf = Gtk.IconTheme.load_icon_for_scale(
gi.repository.GLib.GError: gtk-icon-theme-error-quark: Icon 'org.gajim.Gajim-symbolic' not present in theme Adwaita (0)

I installed gajim in Whonix 17 with command - sudo apt install gajim (but when i tried installing gajim in Debian 12 it’s worked fine, this problem has only been seen in Whonix 17)

Maybe my Qubes installed Whonix 17 crookedly, because I asked someone who uses the same version of Qubes and Whonix and it works fine for him.

Someone told me “This looks like a packaging problem then, since the issue is about Adwaita not seeing that icon. Maybe it did not get registered during install or something like that.”

Maybe anyone know which package should be installed?

I apologize - this may be a “clumsy” solution, but

sudo apt-get install gnome-icon-theme

1 Like

Thanks :slight_smile:

1 Like