Fresh Qubes 4.2 install, can't remove fedora-38-xfce template due to default-mgmt-dvm.template

First time using Qubes OS. Really liking it so far, except for the fact that I installed a GNOME template when I meant to install an XFCE template, but whatever :sweat_smile: that’s user error.

I am attempting to migrate from the older fedora-38-xfce template to a Fedora 39 one following the instructions at Templates | Qubes OS. So far I seem to be mostly successful (all my AppVMs and DispVMs are switched over), but for some odd reason I can’t delete the old fedora-38-xfce template.

When I attempt to remove the template in the Qube Manager, I get this error:

This qube cannot be removed. It is used as:

  • template for qube default-mgmt-dvm

If you want to remove this qube, you should remove or change settings of each qube or setting that uses it.

Seems relatively straightforward, but here’s where the plot thickens - there is no default-mgmt-dvm qube visible in the Qube Manager. I can, however, see it in the output of qvm-ls.

According to Fedora 39 templates available; Fedora 38 approaching EOL | Qubes OS, this is apparently a problem only if you’re using Qubes 4.1 (which I am not) or if you have configured updates to use something called “Salt” (don’t know what that is, I didn’t enable that intentionally). The only configuration option I changed away from the defaults during Qubes OS setup is I checked a box that made one of the service VMs into a DispVM rather than a persistent one (probably sys-net, I can’t remember right now however).

So… what should I do? Have I run into a bug? I assume I can just switch the default-mgmt-dvm to Fedora 39 from the terminal, and then delete the old fedora-38-xfce one, but since this is unexpected, I’m hoping for a bit of help.

It’s a hidden qube. You can show it by going to “View” in the Qube Manager and checking “Show internal qubes”. Then you can change its template.

1 Like

The way i solved it is by going into the ‘Qubes Manager’, top left ‘System’ and then ‘Manage templates for qubes’. There you can switch the template.

1 Like

Ah, good to know. I’m downloading the right template this time (fedora-39-xfce), then will update it and then try this.

1 Like

Worked, thank you!

1 Like

I’ve had the same problem than @arraybolt3. Maybe it would be worth to mention it in the how to in-place upgrade Fedora template guide . It would help other users to avoid completely this hitch.

I’ve updated the section on Switching to include this.