Freeze during installation AMD Thinkpad L14 Gen 3

I have an AMD Thinkpad L14 Gen 3 Ryzen 7 PRO 5875U (HCL). I added the kernel parameters recommended in the HCL topic, but am still having an issue: I reach the initial setup screen and within a couple of seconds, my touchpad and buttons stop working. I am unable to continue with the setup.

Any suggestions?

Note: the post was slighty edited for clarity when the topic was split (bold text).

I missed nomodeset the first time. After adding all the below kernel options, I got the installer to start installing, but it froze on “Installing TemplateVM fedora-37”. I could still move the mouse, but the “[Dom0] Qubes OS Setup” window with the progress bar was frozen. I tried again and it got stuck on “Installing TemplateVM whonix-ws-16”

Any ideas?

dom0_max_vcpus=1 dom0_vcpu_pin nomodeset clocksource=tsc tsc=unstable hpetbroadcast=0

I added these by going to the line that loads the kernel vmlinuz and pressing Ctrl + e to go to the end of the line, then typing them in and pressing Ctrl + x

After GRUB, I was receiving the error:

Warning: USB in dom0 is not restricted. Consider rd.qubes.hide_all_usb or usbcore.authorized_default=0

So I added usbcore.authorized_default=0 to the list of boot options. Now it runs “Executing qubes configuration” then, a minute later, an error window pops up:

Qubes initial configuration failed. Login to the system and check /var/log/salt/-minion for details. You can retry configuration by calling ‘sudo qubesctl --all state.highstate’ in dom0 (you will get detailed state there).

I hit “OK” and log in, open a terminal (using the trackpoint; the trackpad doesn’t work) and run

# qubesctl --all state.highstate
Succeeded: 25 (changed=2)
Failed:       4

When I scrolled up, I saw:

[Errno 2] No such file or directory: '/etc/qubes-rpc/qubes.TemplateSearch'

And then the system totally froze. So I hard rebooted and added all the boot flags above (this time rd.qubes.hide_all_us was already there).

I tried various things, but the system kept eventually freezing (and seems to be sluggish as it was before I added those flags), so I added to the end of /etc/default/grub:

# my customizations
GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX dom0_max_vcpus=1 dom0_vcpu_pin nomodeset clocksource=tsc tsc=unstable hpetbroadcast=0

Then ran sudo grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg and rebooted.

Now I’m stuck with a system that keeps freezing.

Could you make a separate thread for your issue? This would give you more chances to receive support fan adding messages to an HCL report :slight_smile:

1 Like

@zaz I think @solene is right, so I went ahead and split the topic to give more visibility to your questions. I edited slightly the first post when doing that, please feel free to correct if I got anything wrong!

Note that the process of splitting a topic leaves a link in the original thread, so folks reading the HCL conversation will still come across your issue.

1 Like

Note that I never used dom0_max_vcpus=1 dom0_vcpu_pin and clocksource=tsc tsc=unstable hpetbroadcast=0 at the same time.
As I can remember, I first used dom0_max_vcpus=1 dom0_vcpu_pin to get installer working. Then I think that after installation was complete and I booted into Qubes, I also added nomodeset.
I then completed all Dom0 updates and only after that I discovered that clocksource=tsc tsc=unstable hpetbroadcast=0 resulted in proper performance. I did not try those earllier. That’s also just those parameters, so no dom0_max_vcpus=1 dom0_vcpu_pin or nomodeset.
Hope this helps you.
Also remove the default quiet parameter to get more information.

EDIT: if touchpad and lower mouse buttons stop working, maybe upper mouse buttons and red ‘trackpoint’ button still can be used.