Freeze during install

Hello everyone, I keep running into a reproducible problem on my laptop when trying to install Qubes 4.0.3 and I was hoping someone could help me out. Basically, every time the install freezes on “installing storaged.x86_64”. Mouse cursor works, but nothing else happens even after giving it over half an hour.

More info:

  • Hardware is supported on paper, CPU supports VT-d and VT-x.
  • I tried using different boot USB’s and different install drives, but to no avail.
  • My device does not support legacy so I’m stuck with UEFI.
  • I did find a post where this issue appeared before with other users: There was some very useful information here, but I’m afraid it’s a bit too technical for a Linux novice like me. I tried editing the kernel boot parameters which worked for some people in that thread (on Windows with gvim and Linux in terminal), but I’m pretty sure I did it wrong because I kept running into the same “installing storaged.x86_64” freeze.
    Or it just didn’t matter, because I don’t think the issue is with nouveau drivers anyway since the installer works just fine until the storaged.x86_64 part.

Any chance that 4.1 will help fix this with the return of a boot menu? Or do I just need to buy a whole different computer that actually works with Qubes out of the box?

I’ve ran out of ideas so any help would be much appreciated!