Frankly I am exauhsted an I feel like I am chasing my tail

I really don’t get this, I am setting up a fedora-38-xfce template for printing scanning etc. I had it working at least for printing and then was going to come back and update scanning.

I went threw a period of time where I had trouble updating dom0 fixed it from the command line by extending a partition. All works well.

Now, I am going back to resolve the scanner issue but I need to print something today.

It’s all gone fam. None of my printers are there. The print setup app tells me I need a password to add a printer now. Oh also the fedora-38-xfce template is obsolete according to the update utility. Why?

I use these tools because I am an advocate of privacy and security. It works better when more people use it because you get that lost in the noise effect. I also understand its not a perfect system. It’s being built by a small team. But this makes no sense.

I need to be able to do basic functions like print scan without having to set things up again and again. If a system can only be used by haxors and programmers. It fails to be useful to me at least as a power user. So it brings me to a question.

Whom is this OS for? My original assumption was this was privacy and security oriented Xen hypervisor, awesome. Much of the work snowden does is with media types. There not going to be able to use this. I couldn’t so much as start a flyer campaign to elect me to town council right now because I can’t print. People in the news need to print and scan.

I get the basic of how this works I have to setup a template with all the software to do what I want then create a qube that will do it. I never even made the qube. The Template I was testing in lost all my details! I have to print a letter for business today. Or guess not.

Is it made that way on purpose. I am either clearly missing something here or I am falling threw the multiverse like some strange version of ground hogs day.

I hate to gripe but I am at that point where I needed to vent. I haven’t given up yet but to quote charlie brown “Ughh”.

All this said qubes is very impressive an I have to tell the qubes team great work so far. Maybe a qube premade for printing and scanning with gimp, Xsane, and cups already setupwould smooth this bit out for future users.

3 Likes

Sounds like standard CUPS, you need to log in to use it

2 Likes

In addition, Fedora 38 is currently scheduled to reach EOL (end-of-life) on 2024-05-14 (approximately three months from now). Please upgrade all of your Fedora templates and standalones by that date.

2 Likes

What are you talking about today is Wednesday 2024-07-10. The S&P 500 closed at 5,633.91. If your in February you might be able to take advantage of that. It dips in may to 4967.23 on April 19th. Might be a good day to buy a bunch a ATM Calls?

LoL

If it works out for you cut me in for 10%

1 Like

Thanks for the link I saved it for latter use. It’s still not working in the cube for different reasons but get this I logged in today and it worked XSANE scanned Libre office printed etc. Sigh. At this time clearly the real knock though is the “cube” dose not carry it forward from the template. B.S. if you ask me but that’s how it works I guess.

You should follow and read the link that was provided, unfortunately
dated 02/13/24. @apparatus is not in the past, just quoting from it.

I never presume to speak for the Qubes team.
When I comment in the Forum I speak for myself.

It seems like the the problem either revolves around aforementioned CUPS user password thing or persistency. If you create a template and configure the printers there, upon making a qube based on this template the configuration should be lost (unless apps you’re using store the configuration system-wide and not in the home directory), because home directory for an app qube user is initially copied from /etc/skel/. You can push your configs there in the template to get pre-configured app qubes!

It’s not uncommon to be frustrated when trying to set up workflow in something as sophisticated as qubes, and there is no reason to push yourself too hard into it. As a middle ground, it is always possible to just use standalones and hone your system further when a more favourable opportunity comes. To do this, just create a standalone by cloning your template.

I hope you have successfully completed your setup. Keep at it!