Framework AMD Ryzen - R4.2.0-rc5 (sys-usb not working)

I’m trying to set up a Framework laptop with Qubes OS.

R4.2.0-rc4 can be installed (mouse pad not working), but R4.2.0-rc5 doesn’t work with USB at all. The sys-usb cannot start and throws the error similar to sys-usb Suddenly Stopped Working: qrexec-daemon.c:135sigchld_parent_handler: Connection to the VM failed · Issue #7961 · QubesOS/qubes-issues · GitHub

If you upgrade from rc4 to rc5, the error appears after upgrading. After the next reboot, the whole OS keeps crashing if you try to start sys-usb.

Also, I wasn’t able to get the screen working (only with nomodeset).

I have tried R4.1.2, but the installer won’t even start (waiting for udev). There seems to be an issue with NVMe drives or something.

I’m grateful for suggestions/help.

Maybe related to your issue:

Have you tried with kernel-latest?

I was able to solve this problem by desafecting the PCI thunderbolt 4 peripherals to sys-usb.

qvm-pci ls sys-usb
qvm-pci detach sys-usb <target PCI>

kernel-latest fixed the sys-usb issue

I’m still struggling to get an external display to work though.

I can use an external display with 4.2 using either :

  • The HDMI expansion card
  • a USB-C HUB with HDMI output
  • a Thunderbotlt/USB-C dock with HDMI output

Did you try to put the expansion card in different slots ?
I use ports 1 and 3 for USB-C (see ).

Thanks for the link, I’m aware of the port configuration! I tried the setup with Windows, Manjaro and Mint and all of them work out of the box.

Did u configure or install anything additionally, or did it just work after running the installer? Which version of 4.2 are u using?

This is a fresh install of 4.2.0-rc5, no extra.
Note : I do not use sys-gui. Dom0 is responsible for the display.

I re-installed it RC5 + kernel latest. That worked for me.

Touchpad is still not working as expected. There is now one other oddity, though: My screen turns black after the hard disk password dialog is loaded. It returns, once the correct password is entered.

Same here. Just press ESC when the screen is black and you get the text prompt.

Thanks, that’s a good workaround!