Framework 13 - AMD Ryzen 5 7640U - Broken install/upgrade


I recently got myself a framework laptop with the intention of installing QubesOS (waited for the R4.2).

The installation process goes without too much trouble, the touchpad doesn’t work, but I can manage my way around it.

I did the installation with kernel-latest 6.6 (later tried booting with kernel 6.2 and it just plain reboot).

First boot I am greeted with the configurator for my system, choose the option I want and it still works (except the touchpad).

I upgraded my templates and installed some more (fedora-39-minimal and debian-12-minimal), then rebooted my machine to get them applied and now sys-usb won’t boot so I can’t connect a usb mouse…

I tried testing several kernel for sys-usb (6.6 and 6.2) nothing seems to work, and for the touchpad, I search the web, and found no fix.

Is there anything I should try before using the ISO to repair the install ? And what can I do to avoid this again ?

Thank you, and happy New Year ! :smiley:

Yup, seems to be the same issue, although newer kernel (6.6 vs the 6.5 of R4.2rc5) seems to have worsen the issue…

So nothing to do apart from waiting ? I can’t really use my laptop (can’t connect to internet and can’t have usb mouse)

Going to try to change sys-usb base template to something more recent to see if this fix anything.