Followed app install procedures but software won't show in app qube

I have searched and can’t seem to find an answer to these questions.

All are debian based.

I have been successfully installing software in templates and successfully having this software populate the app vms from their respective templates. I seem to have trouble with Libre Office however. Usual procedure, install in the template, shut it down and then start the app vm to populate, but for some reason Libre Office won’t get passed on to the app vm. I find myself having to install it in the app vm where I want it.

On another matter with software, I have tried to install software in app vms to see that it works ok before I install it in the template. For some reason I can install the software, it works, but when I close the vm and restart it the software is no longer installed. Two good examples of this are veracrypt (which I posted about elsewhere but no one has come to my rescue with that one), and the mullvad deb package. Both work via terminal (they don’t appear in qube settings>applications but disappear on restart.

Am i doing something wrong here?

I am particularly puzzled by Libre Office as I use the same method for other software without incident.

Thanks for any help offered.

Concerning LibreOffice, it looks strange to me. It works as expected on my Debian-based AppVMs: I install in templates and it appears in AppVMs. Did you try to re-create a clean template for testing?

This is as expected. AppVMs get new root filesystem from the templates every reboot.

1 Like

Thanks for the reply. No I didn’t try a clean template, but I will. I have had this problem before with Libre Office in qubes but not brought it to attention.

But, I CAN install Libre Office in the app vm and it continues to work. So I don’t see how that is possible with your explanation of how the app vm resets on each reboot?

I will also add that I can install veracrypt 1.25.9 in my whonix template where it will work via terminal but, as with the other, it disappears on restart. In the template. This problem is particularly driving me mad as I want to get veracrpt working. I have two laptops with qubes and its the same on both which puzzles me as my research seems to show that veracrypt is readily able to be installed in whonix. But, again, I haven’t tried with a clean template which I will do.

Thanks for taking the time to reply.

If the app is installed in /home directory, for example, it should survive reboot.

I hope I don’t show just how inexperienced I am. But I’m assuming that documents, downloads etc are in my home directory? I’m generally installing these from either documents or downloads.

There is no problem in showing that. Nobody knows everything from the beginning.

Yes.

It matters, to where you are installing that. There is usually a possibility of non-root install, which uses the home directory.

See also:

Thanks for that link.

Well I seemed now to have solved some of my problems. For example, in a template, I had a folder called “mullvad” in “documents” and I installed it from there using root privileges. This did not persist. So I moved folder up one level so it appeared alongside “documents”, “downloads” etc. This method allowed for persistence. It also persisted to an app vm made from the template. But mullvad does not appear in qube settings > applications. But opening from a terminal and its there (how to get a mulvad gui is another wrestle I’m having for some reason…but I digress). So that issue seems to have resolved as I can use it from the terminal.

Likewise a problem I’ve been having with veracrypt installing in whonix was solved in the exact same manner. Now I have it persisting. But this one has another quirk in that I can make an app vm from the ws-16 template and veracrypt appears in qubes settings > applications, as it should, and it works fine. BUT…while it persists in the template in that I can bring it up from a terminal, it doesn’t appear in qubes settings > applications for some reason. I have restarted it, made other vms from this template where it appears in “applications” yet it refuses to show in the template vm. Beats me.

I have yet to experiment with Libre Office which I hope to get to this week.

I am puzzled as to why things didn’t persist when installed from “documents” “downloads” etc which are in the “home” folder. I was installing using

            sudo gdebi "mullvad.deb"

which installed fine. I have no idea as to the “where” it was being installed.

But thanks so much for pointing me in the correct direction which also provided me with a solution.

So, if I am not installing directly from a terminal and instead, such as with veracrypt, I download a deb package, what folder should I put it in then install from?

See also: How to install software | Qubes OS.

Thanks for that. I didn’t know about that link.

I will also say that I did try installing mullvad via the terminal which made no difference.

But I’ll read up that later as there’s a heap there I didn’t know. Thanks a ton.

Recommended reading:

  • persistence vs. inheirtance (qube doc) - what the template gets to keep and pass on to the app qube
  • bind-dirs - advanced stuff that lets you keep other directories intact when you base an app qube on it

Thanks for those links. I’ll follow up.

1 Like