Firefox on fedora doesn't display certain characters correctly


Since Fedora 39 I start noticing that Firefox no longer renders certain characters correctly, instead I get the unicode number for the unsupported character.

Below is a screenshot of the page Firefox renders when accessing Unicode 2.0 test page

I initially thought it might be a problem with the encoding (currently using C.UTF-8) and tried to change it, but to no avail.
The same characters are displayed correctly in all other browsers (including lynx - text browser), which seems to indicate that this is not due to a missing font, but rather something specific to Firefox.

I wonder if anyone has encountered this problem or has any ideas on how to solve it?

1 Like

Does it work on Fedora-40?

Nope, same problem. Tried both with a new fresh template and also did an in-place upgrade. Both result in the same behavior in Firefox.

I have a similar issue as well. On Wikipedia, foreign language characters don’t render at all (Japanese, Chinese, Farsi etc)

My hope is that it gets fixed in Qubes 4.3 :crossed_fingers:

Is there a way to swap the base OS template from fedora-39-xfce to fedora-40 or do you mean adding it on as another template in Qubes OS?

Related Github Issue #5937:

Pay attention specifically to the latest comments. Marek’s pull request was opened last week.

For the meantime, you could install @fonts group in the template manually.

  1. Read the information:
sudo dnf group info fonts
  1. Compare my suggestion with Marek’s commit.
  2. Finally install the fonts group
sudo dnf group install fonts

Or you could try that in a disposable AppVM 1st to see if it fixes your problem. Then do it.


That solved the problem, amazing @alimirjamali !
I never suspected it was related to missing fonts as it only affected Firefox and not other browsers using the same template.
After the group install of @fonts, everything renders as it should.

Thank you very much!