Firefox not running in fedora 38 appVM

My firefox is not starting in my fedora 38 appVM.
I get the popup dialog saying that appVM has started, but the qube is not displayed.
I can see it running in the Qube Manager. The status column has a green dot.

I checked out the logs of the appVM but did not find any error messages.

Steps to debug:

  1. I uninstalled and then installed Firefox again in the Template VM - Firefox v118
    It shows up under Applications tab in the Qube settings of the TemplateVM.

  2. Rebooted may laptop.

  3. Trief three versions of Firefox:

  1. FIrefox
  2. Firefox on X11
  3. Firefox on Wayland
    I have tried all three and the qube still does not show.
  1. Updated my fedora 38 through the Update Launcher.

Any suggestions as to where the problem lies- application or qube or network.


It’s a known bug. I believe one work around is starting firefox through xterm in the fedora-38 appvm.
(execute" firefox" in a shell).

If you find out a solution to fix it permanently let me know here too :slight_smile:
EDIT: I’m assuming your running Qubes 4.2.0-rc3 too.

thank you ! That worked.

Yes, I am running Qubes 4.2.

No problem :slight_smile:

I noticed two new entries in the available applications of my fedora xfce template after the update one was “Firefox on Wayland” and another one was “Firefox on x11” I also saw that these applications were not installed so I installed “firefox-wayland”

I switched my app menu to the wayland version and i can now open firefox with my old firefox profile again.

I haven’t bothered with the x11.

1 Like
1 Like

You can find the answer here:

Basically a workaround is to comment out a line in the firefox.desktop file that specifies the app to be launched from the dbus activation mechanism. Apparently the wrong name is currently being used to launch the app. Turning off this feature via commenting that line out allows a fallback mechanism to launch the app correctly.

1 Like