Fedora36 and Whonix-gw-16 templates bricked after upgrade

today I updated Fedora36 and Whonix-gw-16 via Qubes Update tool.
Unfortunately, while upgrading, my screen completely freezed and couldn’t even move the cursor. I also tried to close the screen/hibernate the computer, but at the end I was forced to turn it off.

Now, when I start Qubes, every AppVM and Service (like sys-net and sys-firewall) which are based on Fedora36 and whonix cannot start, since they bricked while upgrading. I cannot even try to update again since even the disposable mgmt templates are broken.

What’s the best way to fix it?

I was thinking that maybe I can change sys-net and sys-firewall to debian template. Waiting for some instructions.

Try to revert the root volume to an older state (should be the first one) with qvm-volume:

You would do something like qvm-volume info fedora-36:root to see the available snapshot and do qvm-volume revert fedora-36:root <revision number> to revert the volume. Once done, start the template and see if it boots up.

1 Like

Tried. Template is not starting.

Try to switch to Debian then, it should have what you need to start up your sys-net qube.

Managed to start sys-net and sys-firewall by switching the template to Debian.

In any case, I am not able to upgrade/fix the fedora-36 and whonix-16 templates since even the disposable/management templates are bricked.

Trying to fix it by myself.
If you have any advice please share it here.

I am also considering reinstalling completely the templates, but I did various template tweaks and I dont’ want to lose everything…

If you didn’t clone it or the volume revert didn’t work then I don’t think there’s anything else you can do. I think it’s better to reinstall and go back to a fresh template state.

I tried to update it by installing fedora-36-minimal template and by creating a fedora-36-minimal-dvm AppVM.
I then proceeded to set default-mgmt-dvm's template to fedora-36-minimal and by setting fedora-36-minimal-dvm as default disposable template.

I also tried to set fedora-36-minimal-dvm as fedora-36 template’s default disposable template.

It didn’t work. Cannot update fedora-36 and whonix-gw-16 templates. They are bricked.
Some advices?

I tried everything… I must reinstall the template. Thanks for the help.