Fedora34 wont upgrade, i dont know

try to upgrade fedora use dom0 upgrade and fail on whonix and direct from network, try in terminal

no work

i am upset

Updating fedora-34

Error on updating fedora-34: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=fedora-34’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20.

        ID: dnf-and-rpm
  Function: pkg.installed
    Result: True
   Comment: All specified packages are already installed and are at the desired version
   Started: 17:40:52.370847
  Duration: 460.898 ms

        ID: /usr/lib/rpm/macros.d/macros.qubes
  Function: file.absent
    Result: True
   Comment: File /usr/lib/rpm/macros.d/macros.qubes is not present
   Started: 17:40:52.835573
  Duration: 0.475 ms

        ID: dnf-makecache
  Function: cmd.script
    Result: False
   Comment: Could not create DNF metadata cache
   Started: 17:40:52.836747
  Duration: 623010.312 ms

        ID: Disable deltarpm
  Function: file.append
      Name: /etc/dnf/dnf.conf
    Result: True
   Comment: File /etc/dnf/dnf.conf is in correct state
   Started: 17:51:15.847274
  Duration: 1.545 ms

        ID: update
  Function: pkg.uptodate
    Result: False
   Comment: One or more requisite failed: update.qubes-vm.dnf-makecache
   Started: 17:51:15.849287
  Duration: 0.003 ms

        ID: notify-updates
  Function: cmd.run
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: False
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
   Started: 17:51:15.849326
  Duration: 312039.391 ms
                Error: Failed to download metadata for repo 'fedora': Cannot prepare internal mirrorlist: Curl error (28): Timeout was reached for https://mirrors.fedoraproject.org/metalink?repo=fedora-34&arch=x86_64 [Operation timed out after 30000 milliseconds with 0 out of 0 bytes received]

Summary for fedora-34

Succeeded: 3 (changed=1)
Failed: 3

Total states run: 6
Total run time: 935.513 s

maybe using drugs will help give me a better insightful into why fedora does not upgrade?

ok i am back and feel better

ready for more trying to fix this

i’ll first connect all the templates directly to sys-net to see if fixes problem

edit i am not sure if this fixed problem

i am going to connect sys-usb to sys-net to see if this fixes it

i am going to connect to sys-whonix to sys-usb to see if this fixes

it still is not fixed

its still not fixed! @Sven hellllllp!

you simply don’t have a net connection. Question is now - how are your qubes put together in your qubes manager and whats your updateVM (sys-whonix or something else)?

Usual way to the net should be:

internet ← sys-net ← sys-firewall ← sys-whonix
---------------------------------------------^— appVMs

Error: Failed to download metadata for repo ‘fedora’: Cannot prepare internal mirrorlist: Curl error (28): Timeout was reached forhttps://mirrors.fedoraproject.org/metalink?repo=fedora-34&arch=x86_64 [Operation timed out after 30000 milliseconds with 0 out of 0 bytes received]

It appears you have no network.

i am posting from the machine that has no internet

it has internet

the internet is connected to sys-net to sys-firewall to sys-whonix

i have global settings to get updates/upgrades from whonix

all the other templates did upgrade

i have no idea whats hapening

  1. If you are on R4.0 please post the contents of /etc/qubes-rpc/policy/qubes.UpdatesProxy

  2. Within the fedora template, please try curl --proxy -O https://keys.qubes-os.org/keys/qubes-release-4-signing-key.asc to check the network connection without using dnf

Does sudo dnf update in fedora-34’s terminal works?

If it works, then when using Qubes update to update fedora-34, is default-mgmt-dvm invoked? It might be something wrong with it…

If it’s invoked, does update in it’s terminal works? If it works, then it’s the problem between it and the template. If it doesn’t work then the network doesn’t work,

If it’s not invoked, then it’s the problem of the template, I guess, and you should maybe try to download and install fresh new template.

EDIT: Sorry, @Sven added post while i was preparing mine, so didn’t see it.

$tag:whonix-updatevm $default allow,target=sys-whonix
$tag:whonix-updatevm $anyvm deny

when i did curl in the terminal nothing happened. i saw a bunch of 0s and after a long time shut down the qube

I typed it and it says

Copr repo for PyChar

then it’s a bunch of zeros and lines and nothing happens

I must to download an entire new template? :disappointed:

If those are the only lines you found the problem, make sure you also have the following lines:

$type:TemplateVM        $default        allow,target=sys-whonix
$type:TemplateVM        $anyvm          deny

This confirms no connection, which is not surprising if the above lines are in fact the only ones. $tag:whonix-updatevm identifies only qubes that have the respective tag (you can check with qvm-tags). $type:TemplateVM identifies all templates.

i don’t think it fixed it

i tried your fix @sven but the cirlce thing goe aroun and around. nothing changes

it’s doing what it did before: just showing “Updating fedora-34” for a much time with nothing hapening

is there command or icon for qubes to see rate of download upload?

i think it’s doing no thing

does the disp-mgmt need net access or is that qubes that used for just moving files or upgrade around?

i don’t like connecting to net through system with possible error and not knowing what goes on

it makes more likely i become crushed under wall

from other posts I assume you are on R4.1?

If so that was the wrong file and has no influence on what’s happening. I am not on R4.1 yet personally, but here is an article explaining the difference:

You said all your other templates update fine. What are those? Debian, Whonix?

I have never seen such an output from dnf update. Sorry.