[Fedora 38 => 39] Job qubes-relabel-rw.service/start timeouts

I just migrated my Fedora 38 templates to 39 going trough the bash history to reinstall packages. I also removed / selected a few packages to better reflect today’s needs.

3 out of 10 appVMs are not starting anymore : rw relabeling times out (60s)

I don’t know if it’s relevant, there is this notice just before relabeling service starts :

EXT4-fs (xvdb): mounting with "discard" option, but the device does not support discard
EXT4-fs (xvdb): mounted filesystem aaa-bbb-ccc r/w with ordered data mode. Quota mode: none.

(just changed the uid)

I tried launching them on the base template and another error appears just before :

SELinux:  Context system_u:object_r:snappy_var_lib_t:s0 is not valid (left unmapped).
Job qubes-relabel-rw.service/start running

Some of the - still working - appVMs also have snaps, so snap doesn’t seem to be related.

All 3 appVMs come from the same fedora-38 template. They are still working on this previous template. It is probable I didn’t reinstall all of the packages from the previous template in their new fedora-39 one, could this be an issue ?

How to debug issues related to appVMs initialization ? Is it possible to make rw labeling service or other init services more verbose ?


1 Like

Thanks a lot !

This worked : Timeout starting qube on 4.2 that was restored from a 4.1 backup · Issue #8656 · QubesOS/qubes-issues · GitHub

qvm-prefs --set MYQUBE qrexec_timeout 1200

I didn’t want to fake labeling done with :

sudo mount /dev/qubes_dom0/vm-MYQUBE-private /mnt
sudo touch /mnt/.autorelabel
sudo umount /mnt

qvm-start MYQUBE