Fedora-37 template upgrade problem

I went to the User Documentation / Templates page to see how to upgrade Fedora and I get this error.
I must be overlooking the obvious but every thing I have tried returnes the same error.

sudo qubes-dom0-update qubes-template-fedora-37
Using sys-whonix as UpdateVM to download updates for Dom0; this may take some time…
Unable to detect release version (use ‘–releasever’ to specify release version)
Fedora 25 - x86_64 - Updates 2.5 kB/s | 4.8 kB 00:01
Fedora 25 - x86_64 3.4 kB/s | 5.1 kB 00:01
Qubes Dom0 Repository (updates) 2.1 kB/s | 2.7 kB 00:01
Qubes Templates repository 747 B/s | 1.1 kB 00:01
No match for argument: qubes-template-fedora-37
Error: Unable to find a match: qubes-template-fedora-37

This looks like Qubes OS 4.0. It is not supported anymore, for almost a year and there is no fedora-37 template for it.


Oh no does that mean I have to reinstall Qubes?

See the announcement I linked above, you can also upgrade in place.

1 Like

I marked @marmarek’s post as the solution so that folks with the same issue can find the answer more easily. Feel free to correct if needed @Tbone :slightly_smiling_face: