Fedora-36 to 37 upgrade and sys-usb dvm - how to?

After upgrading to fedora-37 I tried to upgrade the sys-usb to run on fedora-37-dvm from fedora-36-dvm but it won’t happen.
I ran:

qvm-shutdown --wait --all; qvm-prefs <SYS_USB_DISPOSABLE_TEMPLATE> template <NEW_TEMPLATE>; qvm-start <USB_QUBE>

as per documents:

My question is: Does <NEW_TEMPLATE> , in the instructions, mean the disposable template, ie fedora-37-dvm or the base template, fedora-37?

I’m sure in the past I’ve run that command with fedora-xx-dvm as the <NEW_TEMPLATE> and it’s worked properly but I just ran it and it did not change the dvm that sys-usb runs on.
Fortunately it just left it the same as before and restarted it so I did not lose access - my keyboard and mouse use sys-usb.

The documentation makes it look like by <NEW_TEMPLATE> they mean fedora-37, but I’m wary of trying it.

I’ve tried rebooting.


It’s not answer on your question, but this is how I do upgrades. Hopefully at least it might give you an idea to find yourself’s most convenient way to do it.

A template is not the same as a disposable template, so it definitely doesn’t refer to that. <NEW_TEMPLATE> refers to the new template.

Thanks @adw . That has changed the template the dvm is based on to fedora-37 as I wanted.

The documentation was clear in saying that, I just thought I remembered differently.

The only minor issue is that the dvm sys-usb is running on is still named fedora-36-dvm. I can’t shut it down to change it’s name.

I can make a clone with the correct name but not shut sys-usb down to change to that dvm.

I expect the

command can be modified to rename it though.

Any suggestions gratefully accepted or I can look through the docs tomorrow.

Thanks again.

Thanks for ignoring.

If you would use GUi, things would be much easier. Clone sys-usb-36, name it sys-usb-37 and base it on fedora-37-dm. Attach the same USB-controller to it and set autostart. Update RPC polices with the new sys-usb-37 names, so you could access your mouse and keyboard.

Uncheck autostart for sys-usb-36.


Delete sys-usb-36.

@tempmail ,you’re right, I did ignore you. I apologise. I’ll do what you suggest.


1 Like