Fedora-34-xfce AppVM has Screensaver and Lockscreen Enabled

The following images show the lockscreen for the fedora-34-xfce-based AppVM. It shows as a maximised window (with borders) and then a dom0 warning telling us about the VM having tried to create a fullscreen element when not allowed ("As a protection measure, the “override…”

Haven’t found this yet on QubesIssues. Anyone having the same thing?

Definitely seems like a bug.

I was sure, that xfce4 template is for gui-vm only. Are you testing gui-vm?

I dont believe this is true, since the template is available in 4.0
where there is no gui-vm.
If this is the case I would expect these to be services that would be
Qubes controlled - enabled in gui-vm and disabled by default.
We have an existing issue on this, and this report should be added to

You are correct - this is a bug. Screenlocker should be active only in GUI VM, not anything based on the xfce template.
There is kind-of related change here: Do not disable xscreensaver in sys-gui · QubesOS/qubes-mgmt-salt-dom0-virtual-machines@1d20b65 · GitHub, but in fact a broader change is needed - not only keep it active in GUI VM, but also disable everywhere else.

OK. Then I’ve opened an issue specifically for this as I didn’t know exactly what is was impacted. If it needs to broadened, feel free to edit the issue title.