Fedora 33 Fails to Install: [Failed writing body (8614 != 16384)]

I can’t get the Fedora 33 template downloaded.

‘sudo qubes-dom0-update qubes-template-fedora-33’ yields the error '[Failed writing body (8614 != 16384)]

I’ve tried fiddling with memory sizes in dom0 and sys-firewall to no avail.

Bumping this thread. Can anyone help here?

It looks like curl inside of the package manager is getting the file chunk and trying to write it, but cant (curls “failed writing body” is error 23 and I think the numbers would kinda appear like it tried to write 16384 bytes but could only write 8614)

In a dom0 terminal, run

df -h

Make sure you have available space for dom0

My two cents: Not enough disk size for Dom0 UpdateVM.

If that is based on a fedora template, expanding the system storage size of the template might be a good idea.

1 Like

good call

I went back to the fedora 32 template, which allowed a change to the system storage max. I doubled it to 20G.

Problem solved, I have fedora-33 template installed and functional.

Much appreciated.

I did a lot of fiddling with settings, but a poor job of recording initial values for reset. Could someone help with standard (initial) settings for:

Minimal Qube memory
dom0 memory boost

Private storage (presumably this will revert once the fedora 33 template is employed)

Also, a question. Why doesn’t the System Storage max setting in the fedora-32 template get carried forward to the virtual machines? The System Storage max setting in sys-firewall is grayed out (understandable) but still set to the old value of 10G?

Thanks for the help everyone. I appreciate it.