Fedora-32 not updating again and no sound since last time

A while back my fedora-32 template VM stopped updating, via the Qubes Update gear icon in the tray. I could update via the Open Qube Manager, then update method. With forum help I did manage to “fix” this problem using a command, which included an --erase command (I’ve forgotten the complete command used.) But since then the fedora based VMs have not been able to play any sound, including the disposable VM, which I use to open for example mp4’s received in emails. I think it might have been a pulseaudio problem. As of yesterday though, the fedora-32 template is now back to the no-update mode using the gear icon. The error message is, Rendering SLS ‘base:update.qubes-vm’ failed: Jinja variable ‘dict object’ has no attribute ‘os’ Is there a fix for this? I hesitate to find and use the same Terminal command as last time, since it caused the sound problems. Thanks.

What happens if you open a terminal in the fedora-32 template and do sudo dnf update ?

The error message looks like it has to do with the Python Flask framework.

Thanks Plum. Mixed results. Still no fix for the no sound problem. However your suggestion did result in quite a bit of updating being done successfully, as listed below. After a reboot and letting the system do it’s thing, the gear icon has disappeared. I will report back after the next time fedora-32 updates are listed as available in the tray and I run “update” via the gear icon method. By the way Plum, does your method work differently, than opening the Qubes Manager program, starting the fedora-32 vm and clicking on the blue down-arrow update button? cheers. Terminal output below from the update:

6_64/build M=/var/lib/dkms/u2mfn/4.0.31/build…
cleaning build area…

DKMS: build completed.

Running module version sanity check.

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/5.9.14-100.fc32.x86_64/extra/
      Adding any weak-modules


DKMS: install completed.

Running scriptlet: bolt-0.9-1.fc32.x86_64 18/18
Verifying : kernel-5.9.14-100.fc32.x86_64 1/18
Verifying : kernel-core-5.9.14-100.fc32.x86_64 2/18
Verifying : kernel-debug-devel-5.9.14-100.fc32.x86_64 3/18
Verifying : kernel-devel-5.9.14-100.fc32.x86_64 4/18
Verifying : kernel-modules-5.9.14-100.fc32.x86_64 5/18
Verifying : bolt-0.9.1-1.fc32.x86_64 6/18
Verifying : bolt-0.9-1.fc32.x86_64 7/18
Verifying : cups-filters-1.28.6-1.fc32.x86_64 8/18
Verifying : cups-filters-1.28.5-3.fc32.x86_64 9/18
Verifying : cups-filters-libs-1.28.6-1.fc32.x86_64 10/18
Verifying : cups-filters-libs-1.28.5-3.fc32.x86_64 11/18
Verifying : hwdata-0.342-1.fc32.noarch 12/18
Verifying : hwdata-0.341-1.fc32.noarch 13/18
Verifying : kernel-5.9.11-100.fc32.x86_64 14/18
Verifying : kernel-core-5.9.11-100.fc32.x86_64 15/18
Verifying : kernel-debug-devel-5.9.11-100.fc32.x86_64 16/18
Verifying : kernel-devel-5.9.11-100.fc32.x86_64 17/18
Verifying : kernel-modules-5.9.11-100.fc32.x86_64 18/18
Notifying dom0 about installed applications

bolt-0.9.1-1.fc32.x86_64 cups-filters-1.28.6-1.fc32.x86_64
cups-filters-libs-1.28.6-1.fc32.x86_64 hwdata-0.342-1.fc32.noarch

kernel-5.9.14-100.fc32.x86_64 kernel-core-5.9.14-100.fc32.x86_64
kernel-debug-devel-5.9.14-100.fc32.x86_64 kernel-devel-5.9.14-100.fc32.x86_64

kernel-5.9.11-100.fc32.x86_64 kernel-core-5.9.11-100.fc32.x86_64
kernel-debug-devel-5.9.11-100.fc32.x86_64 kernel-devel-5.9.11-100.fc32.x86_64

I believe that if you have used the erase option then you need to reinstall pulsaudio to get your sound working again. Try running sudo dnf install pulseaudio-qubes in the fedora-32 template vm.

Thanks Rooftop. No joy on the sound problem yet though. Still no sound on anything with a fedora based template, including the disposable vm unfortunately. I did find the command, which was suggested before to get the fedora template to update, which did work for a while for updating, but also seemingly killed the sound. It was,


dnf best --allowerasing

I used this after reading another thread on this forum, by a user who was also having difficulty at the time updating his/her fedora.

Probably, I thought maybe missing out that extra step might help. I updated Fedora-32 yesterday and it worked fine with no audio problems. You could try reinstalling Fedora-32 as a new template, although I realise that’s a pain.

That’s a good idea Plum; thanks for your help. When I booted the Desktop computer this morning, clicking on the gear icon showed fedora-32 updates available again. Clicking to install them, resulted in failure of the update process again with the no os Jinja error message. Still no sound on the fedora-32 side as well. The debian vm’s play sound fine. I believe there is a fedora-32 template available on the Qubes site. So I will reinstall the fedora-32 template. cheers

Reinstalled the fedora-32 template, rebooted, couldn’t update via the “gear icon”, so updated using Qube Manager. Half an hour of 900+ files updated in fedora-32, seemingly successfully. Rebooted, then ran Qubes Menu - System Tools - Qubes Update and the process has failed again. Error msg, Rendering SLS ‘base:update.qubes-vm’ failed: Jinja variable ‘dict object’ has no attribute ‘os’.

This could be related to this bug (see the comment here).

Try running sudo dnf upgrade in a terminal in the fedora-32 template. If that works I think future upgrades via Qubes Updates will work.

Sound now works in fedora-32 based VMs. Updates attempted using the cog wheel in the tray are still unsuccessful. However I have just successfully updated via Qube Manager.

1 Like