Fedora 30 displays squares (▯) instead of characters

Hello there. After seeing that Fedora 30 was EOL, I decided to upgrade the Fedora template to 32.
I executed:

sudo qubes-dom0-update qubes-template-fedora-32

and it all went smoothly, I changed the TemplateVMs to all the AppVMs, reinstalled some programs and it seemed to work fine at first.

But then, when I was using snap to install a cryptocurrency wallet app (galleon from cryptonomic.tech, version 1.1.6-beta) it showed a weird behavior, when I click on the button to open the file (Open Existing Wallet -> Select Wallet File) the window popping to browse for the file has ALL the characters are appears as little squares blocks (□), all the filenames, menus, contextual menu, the path, everything.
I switched the template to Fedora 31 and loaded totally fine, but back on Fedora 32 it was all □□□s all over.

So ok, that was weird. Some how everything worked, and I was able to blindly find the wallet file and open it, so it is functional but illegible.
So I thought it was something weird going on with the galleon app, snap or the Fedora32 template that broke something somewhere.

But today, I am using the whonix dispVM, and I encounter a familiar sight…
I opened in firefox (Tor Browser 10.0.5) -> Library -> Downloads -> Show Downloads Folder -> Right click -> Open Terminal Here

But this doesn’t make sense, this is not based on Fedora32.
I never did anything weird to the whonix-ws-15, I just updated them regularly, and I never before had a problem like this.
Something interesting though is that the Terminal only shows the following prompt (copy pasted the squares), so behind the squares in the terminal it only shows:


Which is also weird, as normally when you open a terminal in whonix, it shows the whonix banner filling the screen with the legal warnings and the copyright and later the prompt should show:


So I wonder, why isn’t the screen covered with squares, why is showing a different output?

If I open a new Tor Browser dispVM, and follow the exact same steps I get the squared prompt and terminal, including the contextual menu in Terminal is all squared.
But if I directly select a terminal from the menu, it fires up a new dispVM with a legible terminal, if I then execute torbrowser and then follow the above mentioned steps, I still get a normal terminal.

I am completely lost and I don’t even know where to start looking for an answer. What is going on with all these random squares? Any hypothesis?

It looks like you’ve done a fair amount of customization in dom0. My only guess would be that something having to do with the characters (e.g., the character encoding) is incompatible between the domUs and dom0, such that dom0 is not recognizing the characters correctly and is rendering just squares instead. But this is really just a guess.

Perhaps folks with more experience in this area will be able to help you diagnose, but it might help them if you detailed the relevant changes you’ve made in dom0.

Thanks for replying!
The only “customization” that I made in Dom0 was installing redshift, but that was it and that was almost a year ago and I never had any problems until now.

These encoding problems only started to happen after downloading the fedora-32 template.
And I thought that was a completely logical explanation for the galleon app misbehavior… (as it doesn’t misbehave if I revert it back to Fedora-31).

But I can’t find a logical explanation for the whonix dispVM, as its template was never “customized”, I am just religiously keeping it updated to the latest upgrades.
What is really puzzling is that if I open Terminal -> Firefox -> Terminal it doesn’t show this encoding problem.
But if I fire up the DispVM from Firefox -> Terminal, it does.

It appears that there are additional customizations in dom0 besides this. For example, I noticed that the font used for the text in the Window Buttons (as Xfce calls them) in the top panel appears to be different from the default. This text is also visible in the clock and username in the upper right. The color scheme of your Notification Area also appears different from the default (more monochrome). Your window manager also appears to be drawing different window borders than the default, with a block-like pattern around the top center of the title bar.

I can confirm that I have seen these before, too. In my case it occurred under the following circumstances:

  1. Install Fedora-32 TemplateVM with snapd and qubes-snapd-helper.
  2. Install the VSCodium Snap Package inside a AppVM that is based on it (snap install codium --classic).
  3. Nautilus inside VSCodium is affected. Everything else works.

(I might need to at that this is the Qubes 4.1 already.)

Hi @prostagma,
some missing fonts… Did you remove some fonts?
Just a very basic idea, did you change the language (locale setting) for some AppVM/TemplateVM to a non-English language? (Japanese for example, because your username is Shinji).
Also, could you test a xterm (not a xfce-terminal).

(@prostagma, I’ve renamed the thread to make it easier for others to find, but thanks for the initial creativity)