False monitor resolution

How can I do this? After the error occurs just nothing happens.

Boot the system so that this error occurs.
Boot with nomodeset so you’ll boot normally.
Check the previous boot log when the error occurred using this command:

journalctl -b-1

This error also occurs with nomodeset.

How did you boot without the errors previously? Boot in a way that’ll allow you to use dom0 to check the log.

This is unfortunately a new error that happens since i did ./nvidia-xconfig

Remove rd.driver.blacklist=nouveau from the GRUB if you have it there. Maybe also add rd.driver.blacklist=nvidia, but I’m not sure if it’s needed.

Tried a few combinations, including this one. It’s still not working. Do you know if I can create an backup by copying the directorys of qubes from a live os?

I’m gonna try a few more things, but I want to prepare for the worst case.

You can only backup the data inside your qubes, you can’t backup the Qubes OS configuration.
You can’t create a complete backup using Qubes Backup tool to restore it later using Restore Backup tool.

You can try to switch to another TTY on your error screen with failed lightdm during boot using Ctrl+Alt+F2 to access the dom0 terminal and try to remove/fix your nvidia proprietary driver.

Was able to fix it. Didn’t know about Ctrl+Alt+F2, thanks!

Got it. Somehow i got the wrong kernel version (that is my current assumption).

can i just delete the old kernel directory /lib/modules/6.6.21-1…/ (with rm-rf /lib/modules/6.6.21-1…)? Or can there be any errors that would break a lot of things?

I don’t think that removing the directory manually is a good idea.
If you want to remove the old kernel then remove it using dnf e.g.:

sudo dnf remove kernel-6.6.21-1

You can list the installed kernels using this command:

dnf list installed kernel kernel-latest


So, now again.

  1. I followed this guide: Nvidia proprietary driver installation
  2. It’s not working
  3. I follow the nvidia troubleshooting guide Nvidia Troubleshooting Guide
  4. It’s not working

But a few advancements were made:

  • nvidia is now active as described in the installation docu
  • nvidia driver seems to be loaded
  • but: nouveau seems also to be active (or something like that; the instlalation docu said that there should be no output)
  • but nouveau driver seems to not be loaded

You can check the driver used by your GPU using this command:

lspci -s 01:00.0 -k

If you have lightdm error then check the journalctl to see the reason why lightdm failed to start.
Or if you’re in dom0 TTY using Ctrl+Alt+F2 then you can check the service log:

sudo systemctl status lightdm


journalctl -b -u lightdm

The nvidia kernel driver is in use :slight_smile: But still nothing happens after the luks decryption. (Tried the solution of the other person you helped with the similar usse, but qubes.skip_autostart didn’t work). & I don’t find any logs with errors.

I was able to solve the lightdm error. The only problem is: i have no desktop/screen. Nothing loads after the decryption, but I am always able to to strg+alt+f2 (that how i got the picture).

What’s the output of this command?

sudo systemctl status lightdm

Do you have only one monitor and it’s connected to your NVIDIA GPU?
Nothing is connected to your motherboard (iGPU)?

This is currently the only monitor & it is connected to the graphics card. nothing is connected to the motherboard.

This is where currently nothing is happening anymore.

Are you testing this with your new monitor? Does your old monitor have the same issue?
Maybe Qubes OS is trying to output the image using your iGPU instead of dGPU for some reason. Or maybe different dGPU port?
Is there an option in your BIOS to select the Primary Graphics card or something similar, where you can select either integrated or dedicated card?
You can also try to blacklist your iGPU driver with this kernel option in GRUB if you have Intel CPU:

So: updates.
Kernel params nomodeset + nouveau.modeset=0 + rd.driver.blacklist=nouveau gives me an picture and lspci shows that nivdia driver is in use! But… it still isn’t the right resolution, the monitor name is not recognized, etc.

I think the problem is that somehow nouveau still starts. I don’t know how, the kernel paramereters seem to not do their job because lsmod grep nnouveau still outputs 10 items…

To your questions: I am mainly trying with my old monitor. But e.g. right now i am trying it with both. Both monitors have the same issues & are from different manufacturers (samsung & acer).

The idea with bios was good & i did it, but it didn’t change anything, as well as rd.driver.blacklist=i915 didn’t change anything.

I think the primary question is: why is nouveau even starting in the first place? It should output nothing & not 10 items.