Failing to Build 4.1 (No matching package to install: qt5-devel)

Hey everybody, soon-to-be (hopefully) first-time user here. I’m trying to build a 4.1 ISO on a fedora 32 VM and the process is failing at a certain point. The build has had several problems which I’ve managed to fix, but I can’t find a solution for this one. When it seemed like the thing was actually going to build (it went on successfully for a couple hours), I got a missing dependency message and the error No matching package to install: qt5-devel. I ran sudo dnf install qt5-devel and installed it, but the error is still there when I try to build again. I’ve looked around for a solution and can’t seem to find one. Qt5 is installed where all the other packages are so I’m not sure what the deal is (I thought it was a path error). Also, I can’t just download the 4.0.4 or signed 4.1 ISOs because I need a newer kernel to even install. I know this is probably a dumb question but I would greatly appreciate any help.

1 Like

(Welcome! Made the title more specific about the issue, feel free to further tweak it)

I stumbled on the same error, and after a bit of debugging it seems qubes-builder doesn’t support fedora-33 (neither as being the vm where the build occurs, nor building fedora-33 template).

So use fedora-32 as your build vm, and also remove fc33 from DIST variables in builder.conf

Yeah, I found that out the hard way by using Fedora 33 first. I was using 32 when getting the error but I didn’t remove fc33 like you suggested, maybe that was it. I ended up using @fepitre 's 4.1 build instead, no issues so far.