Failing to boot 4.1 on Lenovo Legion

Hey dear community,

I am currently trying to migrate from an older Thinkpad to a brand new Legion.
Ryzen 4800H + RTX2060 Configuration.
Secure Boot is disabled.

I already tried:

Booting 4.0.4-rc2 (5.4 stable)
Getting thrown into tmux showing X-Server failed to start.
Currently trying to get more logs out of it but expect not much out of it.

Booting 4.1 from recent qubes openqa compiled iso

Booting 4.1 from self built iso 5.10-x (master branch) (today and some other in the last weeks) :
“ELF: Not an ELF Binary”
“Panic on CPU 0 could not construct domain 0”


(Please note that this screenshot was taken without the _dom0_vcpus_max=1 _ flag but produced the same error)

Googling this lead me to 1898662 – Xen hypervisor wont boot "with not an elf binary" on kernel 5.9.8 - said it is in the stable fedora repo since last month. So no clue if this is cause relevant.

I got around the “black screen during installation” issue by keeping the vga console,
even bought a sub 8gb usb drive to confirm if this affects the boot process.

(Kernel) Flags tried(combined or standalone to test changes)

acpi=off (enabling it leads to "interrupt blocked")
vga=current,keep (fixes the relinquish vga console issue and allows me to see verbose output)
nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
1 Like

Did you try to make your iGPU as primary display in BIOS ?
I also have a Legion but Intel+nVidia

To get mine working I had to set graphics to switchable in bios.