Failed upgrade to 4.2 qrexec-legacy-convert command not found

I tried upgrade in place from 4.1 to 4.2 using the instructions here:

The process was smooth enough, updating of my actual templates ran into some errors, but that’s understandable, for example I had already manually installed and used a debian-12 template. I expected to be able to fix the templates afterwards.

However, the final stage of the upgrade failed, seemingly, with the following error:

/usr/sbin/qubes-dist-upgrade: line 468: qrexec-legacy-convert: command not found

I’m unable to get that step (“STAGE 6”) to run by manually running:

sudo qubes-dist-upgrade -p i get the same error

I’m not sure how to proceed, or how this error could be caused by any particular issue or mistake on my end.

I tried rebooting, and as far as I can tell no upgrade has taken place. None of the new GUI tools are evident, i expected whonix-17 templates to be installed and they are not. How can I troubleshoot or verify my install? Is my only option to try a clean install and restore?

I made some progress. I ran qubes-dist-upgrade again with the -k flag to avoid touching my templates to rule that out. I ran into a salt error on Stage 5 which I may have missed before, and managed to overcome.

Stage 6 is still failing with a series of python errors ending in:

File "/usr/lib/python3.11/site-packages/qrexec/policy/", line 733, in __init__ assert default_target is None or default_target in targets_for_ask

I understand that the update is moving qrexec policy files to a new format, although the old format is still compatible. So i’m probably fine, but I would like to know how to troubleshoot this, how to properly update my policy files. I do have some things in there, like apt-cacher and split-ssh, but i’m a bit lost how to proceed. Is there a guide on how to manually upgrade one’s policy files to the new format?

perhaps this thread’s title can be changed to reflect Upgrade issues with qrexec policy conversion? something to that effect?

Experienced the same. It is stil possible to do an upgrade and let policy in the old format. Anyway, I’d like to know how to successfully convert the policy to the new format. Did You manage that?