Failed Update for fedora-34 & whonix-ws-16 templates - 4.1-rc1

Hi all,

As the title states, I can initiate the update process, but it fails shortly after. Here is the details from Qubes Updater:

Updating fedora-34

Error on updating fedora-34: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=fedora-34', '--show-output', 'state.sls', 'update.qubes-vm']' returned non-zero exit status 1.
fedora-34: ERROR (exception Failed to copy Salt configuration to disp-mgmt-fedora-34)

Updating whonix-ws-16

Error on updating whonix-ws-16: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=whonix-ws-16', '--show-output', 'state.sls', 'update.qubes-vm']' returned non-zero exit status 1.
whonix-ws-16: ERROR (exception Failed to copy Salt configuration to disp-mgmt-whonix-ws-16)

I would appreciate your advice on where to look for more logs and debug info.

What template you default-mgmt-dvm is based on?

It is based on fedora-34

I noticed it too Marek. Spent considerable time over the last several days trying to vary anything that I thought would help before retreating to the Beta version (which I hadn’t tried yet). Thanks ahmed for posting this.

Even though most of my efforts were pretty vanilla (none of mine used encryption nor used whonix for updating thru tor for anything nor debian for the default) I even tried the most vanilla I could manage & the problem remained - installation not a problem but unless I used sudo dnf upgrade in fedora-34 “once” the graphical update tool always failed with this salt error.

1 Like

Check if you see out of PoD memory error in /var/log/xen/console/hypervisor.log. If so, try setting default kernel to an older one (5.10.61 maybe?) - you can do that in Qubes Global Settings.

i have the same problem updating whonix now i have whonix-ws and whonix-gw 15 and 16 and i cannot delete the old ones.

I see that I have out of PoD memory error. The timestamp for the error logs shows that they were from yesterday, even though I restarted the PC and initiated the Updater many times today.

I have changed the default kernel version to 5.10.61 as you have suggested, but the updater still fails with the same log from my original post.