Failed to setup loop device

I try to install Windows 10 as a TemplateVM in Qubes 4.0.1. on a Lenovo T460 laptop with 8Gb memory.
I’m following guide “Windows VM installation” section. I successfully created “Win10_Template” TemplateVM, copied the “Win10_1909_English_x64.iso” file in the Home directory of “personal” AppVM, opened a dom0 terminal and typed in the command: qvm-start --cdrom=personal/Home/Win10_1909_English_x64.iso Win10_Template
I got an error: Failed to setup loop device for /Home/Win10_1909_English_x64.iso
I tried to write also with all lower case and also exactly the same way (lower and upper case) as I can see in Qube Manager but I always got the same error message.
Then I tried to “Boot qube from CDROM” in Qube Manager->Settings->Advanced but then I got “Not enought memory to start domain Win10_Template”. I even tried to increase the initial and max memory to 6Gb but got the same error.
No idea what can the problem be.

how large is the windows 10 iso? @ZoltanG
If the iso is too large (like 5 gb) it will failed to loop
“Not enought memory to start domain Win10_Template” is same as above or that because your laptop only got 8gb

Thanks for your fast reply and help!

Yes, it is 5.4 Gb so that can be the problem. (However then I don’t understand how and why the guide speaks about Windows 10? I haven’t found any Win01 .iso under 5 Gb.)

Anyway, I will try with Win7 x64, that is about 3.6 Gb.

1 Like

it depend on how much ram you have, 5gb iso would be a problem with 8gb computer but not for more than 12gb ram computer

Back to the day i’m still using win, i found a windows 10 iso for 4gb

you should make your windows 7 vm offline since windows 7 reached EOL for more than 2 year now

It should be qvm-start --cdrom=personal:/home/user/Win10…iso Win10_Template

You have tight memory don’t increase it, you should decrease it.