Extremely Bad Audio Lag in Windows VM is Frustrating and Ongoing

This has been a problem with Qubes for a very long time and it still isn’t better

If I use virtual box on very old hardware, I get less sound lagging than I do on Qubes on very good hardware. My hardware specs are good when I am using Qubes, I’ve tried the tricks people have suggested, it’s still really terrible.

I know Xen and VirtualBox and KVM are very different, but this problem is so bad that I have thought of switching to a regular distro and using KVM or at least having a dualboot with a KVM option.

:frowning:

I wish this were a higher priority for the development team. It makes Qubes less usable as a daily driver since many video and audio software is only available in Windows and if a user even occasionally needs to use those things, Qubes is not an easy option.

3 Likes

True.
P.S. I can advise to try USB audio-card or additional PCI audio-card to passthough to Windows qube.

1 Like

It only improves it slightly and it’s still much, much better on VirtualBox or KVM. This is a major problem for Qubes and slightly modifications only make it a bit less terrible. It’s not slightly bad, it’s unusable in some situations.

I do not argue. Just provide a workaround for the sound issue.
I personally think that if the OS takes from the user ability to run VirtualBox or other virtualization software, it should provide own decent virtualization instead (e.g. based on Xen in case of Qubes OS). But currently it’s not what we have.

1 Like

The virtualization is mostly fine for normal use, but this is the one use case in which Qubes is completely unusable.