External monitor no video input over HDMI

I use a T480s with integrated graphics only.
This has worked before without problems, this is the first time im trying external monitor on 4.1 version. The display is fine I have tried on other setups and also tried with TV same thing happens no input signal.

Xrandr shows the monitor
Display settings shows the monitor I can change resolution and everything

Screen stays black it says no video input.
If however I try to set up the screens as mirrored in the display settings both the laptop screen and the external monitor will revert to a weird resolution 1650x1024 or something and then i will get a screen on the monitor full of artifacts.

Can you try to set your setup options in dom0’s terminal using xrandr?
Something like that:

xrandr --output <laptop-monitor> --primary --mode 1920x1080 --output <external-monitor> --mode 1920x1080 --right-of <laptop-monitor>

Replace <laptop-monitor> and <external-monitor> with the name they have in xrandr output.

They are set up like this. Why is it 1920x1080+1920 ? This might be the issue ? what does +1920 mean?

The “+1920” you see refers to the current monitor position (to the right of your primary monitor).
I can’t see the selected mode for the other monitor, is it also on 1920x1080?

Yep, this is the laptop screen

What is the current state of the external monitor, is it still showing “no video input”?
Have you tried live-booting a Linux system like Ubuntu to see if your monitor setup works correctly?

Yeah its just black screen, if I try to replug the cable it will say no video input.
It has to be something with xcfe I think… it should be just plug and play

You said in your main post that it worked before. Was it on Qubes itself or on another distro? Was it recently?

Yeah I’ve been running qubes since like 3.2 with this exact same monitor, never had an issue just plugged it in and it worked. Also wherever I went I could just use hdmi never had an issue.

That being said I have not used hdmi since I reinstalled the os with the 4.1 version.

I’d try the same cable and monitor with another laptop/pc for the next step.