External Monitor and Mouse&Keyboard issues on Qubes 4.2

Hey there,

I use a System76 with AMD Ryzen 7 with Qubes 4.1.2. I use them with no issues.
Lately, I had to pump a little bit the resources so I ordered a Tuxedo system with 64GB RAM, Intel Core i9-13900HX and NVIDIA GeForce RTX 4060 8GB (I don’t care about this one because I don’t use its resources).
After installing the Qubes 4.2 on the new system, I have the following problems:

  • I can’t use the external monitor (which I use on System76 with Qubes 4.1.2). I set from BIOS to use only Intel GPU and it’s still not working. Shall I try to install a separate driver for Nvidia and set it also in BIOS or?
  • I can’t use the keyboard and mouse. I can’t write when Disk password is requested, I can’t write when login password is requested. After logging in, I can use only the mouse after I allow it, but the keyboard is still not working. The same Keyboard and Mouse with the same USB dongle I use on System76 with Q4.1.2 and work.

Out of curiosity, I installed Q4.1.2 and the Keyboard&Mouse problem disappeared which makes me think there is a problem on Q4.2 in handling the USB dongle.
The 2 policies for Mouse and Keyboard are fine:

cat /etc/qubes-rpc/policy/qubes.InputKeyboard
sys-usb dom0 allow
$anyvm $anyvm deny
cat /etc/qubes-rpc/policy/qubes.InputMouse
sys-usb dom0 allow,user=root
$anyvm $anyvm deny

Though, the problem with the monitor(s) still persists in Q4.1.2 as well.

Is there anything that I can try?

Ive just realised that after login, only the mouse works, I get the Allow message only for the mouse. The keyboard is not working and I don’t get any pop up to allow it.

I have same problem on my old laptop. HCL - ASUS TUF Gaming A17 FA707RC . I not solved it, but maybe you can. How i understand hdmi connected to nvidia card, and still not working while you don’t use external gpu. I install nvidia drivers and create custom xorg file, then my external display start working.

I have same problem too. To fix it on install i choose set sys-net and sys-usb as one qube, and delete flag “makes it disposable”

I hope it helps. Luck for you

Ok… so in my case should be the Nvidia GPU which needs the proper and correct driver and not the generic one (nouveau),
The thing is that why do I need the Nvidia driver if the Intel GPU is used? Why the video ports (DP, HDMI) are not working directly with Intel GPU which I strongly believe Qubes OS 4.2.0 has support for.
Did anyone install Nvidia driver recently and can provide me some guidance?

Thank you.