Extending Qubes SSD partition

Hi guys,

I decided to write about this because this is the 3rd fresh install since my qubes system had issues booting due to storage space. I frequently make backups and set the system to turn off after backing up my qubes. Sometimes i run out of space entirely and qubes does not want to boot anymore.

I am currently dual booting windows and qubes. I have tried using disk management and disk part in windows to clear up space to make a larger partition for qubes. However, i got stuck with 2 partitions of unallocated space. Windows did not let me combine them.

Instead, i was hoping the qubes installer will allow me to format and combine both partitions. I had selected both partitions with a combined 308GB of space (208 gb + 100 gb partitions). However, this seems not the case. After completing the install i only see 142 gb available for vm pool data and 19.5 gb for varlibqubes data. Combined this is not even 208 GB. Where did the other 50gb go?

Clicking the attachments icon in the panel, i can see the 100 gb listed under data block devices. I have the option of attaching to appVMs but ideally i wanted it apart of vm pool data because i constantly run out. I have had backups taking up 50 gb of space.

Is there a way to find the lost 50gb of data? Can i extend my current 208 gb partition to include the 100 gb partition without re-installing qubes?

Much thanks :slight_smile:

Only 90% of your disk are used, 10% are left as free space for emergencies in case of out of space.
There’s also a swap volume.
And there’s also a metadata that is using the space in the pool.

I don’t know if it’s possible to extend the existing Qubes OS pool.
I only know that you can create another pool on your second partition:

how can I attach my 100 gb partition to an appvm? I have successfully attached it via the devices icon in the panel but it doesnt show up in file manager for the appvm

hmm strange that its allocated 50gb to swap and emergencies. My last install of qubes on the 208gb partition gave me 171 gb of vm-pool data instead of 142

You need to mount it manually:

1 Like

i tried to attach it to an appvm but running these commands in the appvm terminal is giving an error.


cd ~
mkdir mnt
sudo mount /dev/xvdi2 mnt

Error: special device /dev/nvme0n1p5 does not exist. dmesg(1) may have more information after failed mount system call.

Anyhow, i was able to attach it to dom0 so this solves the problem temporarily. Would be convenient to be able to easily attach it to any appvm of my choosing

Did you read the doc?

If not specified otherwise, block devices will show up as /dev/xvdi* in a linux VM, where * may be the partition-number.

Ik the partition is 5. im getting the same error or xvdi5, xvdj5 etc etc…

Beware that when you attach a whole block device, partitions can be identified by their trailing integer (i.e. /dev/xvdi2 for the second partition, /dev/xvdi for the whole device), whereas if you attach a single partition, the partition has no trailing integer.

I attached the block device to dom0. I wanted to store qubes backup in this device but i get the error:

Failed to get backup summary: insufficient permissions

Is there any easier way to do this? Why didnt qubes combine the partitions during installation when i selected it to do so?

What’s the point of attaching /dev/nvme0n1p5 to dom0 as block device /dev/xvdi if it’s already present in dom0 as block device /dev/nvme0n1p5?

Not sure about this, maybe you need to mount it with user permissions?

Because it wasn’t designed to be installed over multiple partitions?
Merge your free space parts first. You can use gparted for this.

oh it was trying to attach on a seperate appvm using /dec/xvdi. I still havent figured that out yet.

During the installation i selected both partitions thinking it would merge the partitions for me. Would u recommend installing gparted on dom0? I can attach to dom0 and should be able to merge the partitions. I would install on an appvm but i still havent figured out how to attach to an appvm

thanks for your patience :smiley:

To merge the partitions and for Qubes OS to use the full merged partition space you’ll need to reinstall Qubes OS. Or at least I don’t know of any other way.
It’s better to boot from gparted ISO and work with your disk there.

makes sense. How can i mount the partition to dom0 with user permissions?

1 Like