Expected experience after moving SSD to other computer?

Hi. My laptop needed urgent repair, after the CPU fan no longer worked. I took the SSDs out, before giving the device away.

I tried to insert the SSD temporarily into another computer, but despite many attempts with different settings for UEFI/Legacy/compatibility/secure-boot modes, the computer doesn’t find a bootloader, even when I explicitly set the respective SSD as the boot device.

Is this the expected experience?

I intend to move the SSDs back into the original laptop after the repair is completed, so it’s probably best not to modify the existing bootloader on the SSD, in the hope that the bootloader will automatically work again in the original hardware environment.

The SSD has three partitions, an “EFI System” partition (600 MB), a Linux filesystem (for /boot, it has efi and grub directories, kernels and xen), plus the large encrypted luks partition.


Bad timing, there’s a recent grub2-efi-x64 package update in dom0 current-testing which would have avoided this:

If you mount the EFI System partition and copy EFI/qubes/grubx64.efi to EFI/BOOT/BOOTX64.EFI on it (EFI/ is a directory inside of the EFI System partition), your system should be able to boot again after selecting the SSD. This is part of what the package update does, it makes the installation discoverable in the absence of a normal boot entry.

And/or you can recreate the normal Qubes OS boot entry: Search for efibootmgr in the forum or in GitHub issues.


I got the same problem, solved with the help of apparatus here: Can't boot on Qubes (PXE-E61) - #2 by apparatus


Simply copying that file indeed solved the problem, pure magic!
Rustybird, thank you very much!

(BTW, that system is still 4.1.2)

(Also thanks to parulin, I didn’t try your suggestion, because Rustybird’s solution worked for me.)