Ethernet not working: "Device not managed"

Ethernet is not working on my laptop. In network manager under Ethernet it show device not managed. I have followed several troubleshooting articles but nothing worked. It is a xps 13 9380. WiFi works fine and Ethernet works on other Linux distros. I am using the 5.8 kernel in dom0 and 4.xx In net-vm. Any help appreciated.

Any help?

why are using 5.8 kernel in dom0?

I didn’t even know there was one.

Recent kernels help to recognize recent hardware.

It’s available with kernel-latest

Hi @spacetime,
the sys-net VM should recognize the network device (not dom0).
Read the PCI Troubleshooting which is mainly about network devices.
You can change the vm-net kernel to 5.8 kernel (from Qube Setting GUI tool).

hmm, dumb question but does a newer kernel possibly mean, use hardware more safe and efficiently?

I’m a bit reluctant to , otherwise, experiment with dom 0 or U with a -latest

Hi @Clodius,

Stable kernels are for stability and updated when security issues discovered.
Latest-kernel is more for people getting issues with stable kernels, and for people with the required skills. Yes a newer kernel could use hardware more safe and efficiently but also with more risks…

So my humble advice : don’t update if you don’t need it. The Qubes OS team selects the more safe and stable kernel for us.

1 Like