Errors starting VMs on Lenovo IdeaPad

Trying to install on a Lenovo IdeaPad 14api and I keep getting a switch root error trying to start vm’s. I’ve double checked to make sure virtualization is enabled in bios I’ve tried clean installing 3 times, 2 different iso burns to ensure there was an integrity issue.

mount: wrong fs type, bad option, bad superblock on /dev/xvda, missing codepage or helper program, or other error

In some cases useful info is found in syslog try

dmesg tail or so.

Waiting for /dev/xvdd device…

mount: /dev/xvdd is write protected, mounting read-only 1.376007] EXT4-fs (xvdd): mounting ext3 file system using the ext4 subsystem

1.377495] EXT4-fs (xvdd): mounted filesystem with ordered data mode. Opts: (null) mount: mount point /sysroot/lib/modules does not exist

mount: /sysroot not mounted or bad option

In some cases useful info is found in syslog try

dmesg tail or so.

switch_root: failed to mount moving /sysroot to /: Invalid argument.

Switch root: failed. Sorry.

1.387233) Kernel panic not syncing: Attempted to kill init! exitcode=0x00000100

1.387252) CPU: 0 PID: 1 Comm: switch_root Not tainted 5.4.98-1.fc25.qubes.x86_64 #1 1.387268) Hardware name: Xen HUM domu, BIOS 4.8.5-30.fc25 02/18/2021

1.387282] Call Trace:

1.387293) duno stack+0x66/0x91 1.387303) panic+0x109/0x2eb

Have you try with checking media installation first before installing? Maybe there’s a corrupt file.

Yes I’ve checked the installation media. I’ve tried 2 different USB’s and redownloaded the ISO and used Rufus to image the USB’s multiple times, all the same outcome

are you using detachable /boot ? it’s likely the system is crash because i/o error.

I/O and file system performance can be affected by any of the following factors:

  • Data write or read patterns
  • Sequential or random
  • Buffered or Direct IO
  • Data alignment with underlying geometry
  • Block size
  • File system size
  • Journal size and location
  • Recording access times
  • Ensuring data reliability
  • Pre-fetching data
  • Pre-allocating disk space
  • File fragmentation
  • Resource contention

Are you using automatic partition disk when installing ?

I’m using automatic partition on a SSD

Have you seen any error during installation and first initial setup ? and what’s your first initial setup configuration (ex : creating usb qube) ?

Installation is fine with no errors. First boot for initialization results in a single error for sys-firewall

[/usr/bin/qvm-start’, 'sys-firewall] failed:


stderr: "Start failed: internal error: libxenlight failed to create new domain 'sys firewall, see /var/log/libvirt/libxl/libxl-driver.log for details

A: libxt device.c:1999:device_backend_callback: unable to add device with path /local/domain/5/backend/vif/7/0

tubxt create.c:1517:domcreate_attach_devices: unable to add nic devices Libxl device.c1983:11bxt__initiate_device_generic_remove: backend /local/domain/5/backend/vif/7/0 already removed, cleanup frontend only

t: libx linux.c:155:11bx1 loopdev_cleanup: unable to release device /dev/loope: No such device or address

te libxlinux.c:155:11bxl loopdev_cleanup: unable to release device /dev/loope: No such device or address te libx linux.c:155:11bxl loopdev_cleanup: unable to release device /dev/loope: No such device or address

I think the errors occur from xen / kernel.
Would you test with qubes 4.1 ?

Installing it now, will report if it works

Unfortunately this has resulted in the same sys-firewall error during initialization after successful installation

  • In partition disk, can you choose custom install, then delete all pattition in unknown ‘tree’ leaving only your media installion, after that click automatic partition on top, click done then can you take a pict about summary of changes?

  • Proceed with installation.

  • Just install template during first initial setup, don’t create any vm, is there any error occur?

Just tick the template, untick all below.
then in dom0

qubesctl state.sls qvm.sys-net

are there any error ?

qubesctl state.sls qvm.sys-firewall

we will do 1 by 1.

Both executed successfully

Forgot to mention, unticking everything but the templates rendered a new error

[user@dom0 ~]$ qvm-create --template fedora-33 --label red fedora-33-dvm
[user@dom0 ~]$ qvm-prefs fedora-33-dvm template_for_dispvms True
[user@dom0 ~]$ qvm-features fedora-33-dvm appmenus-dispvm 1
[user@dom0 ~]$ qubes-prefs default_dispvm fedora-33-dvm

then try opening firefox on fedora-33-dvm, will that work ?

are sys-firewall and sys-net running without problem now ?

I’m able to run sys-net, no noticeable errors starting it however I get an error trying to stop it. Firewall still unable to start. I’m able to start the dvm however it halts shortly after. Firefox is not installed to try to run. I tried to manually install firefox which resulted in “libdbus cannot open shared object file” when trying to run it. Imgur: The magic of the Internet

okay one more, please provide :

ls -l /dev/disk/by-uuid/
ls -l /dev/disk/by-id/
cat /etc/fstab

I appreciate all of your help, thank you!

looks like you using external device right ?
when sys-firewall running, does dom0 run well ? or the system become unstable and crash ? from my point its look like the system is booted successfully but then device got lost it’s power so that’s maybe the reason your system became unstable and or crash.