Error Writing: read-only file system

I have a laptop with an nvidia graphics card and I knew qubes was going to require some troubleshooting before a successful boot, and i was right. When I attempted booting it, I would get a black screen after some console commands flashed by. When I looked on the qubes website they suggested editing “[qubes verbose]” in the BOOTX64.cfg file and commenting out “noexitboot” and “mapbs”. Every time I attempt to do this I get an error that tells me I cannot edit it because the file is read only, even when I am root. When I type ‘ls -l’ it returns “rw–r–r” which should mean that if I have root access I should be able to edit it but it still doesn’t work. I have been looking for answers for hours. I have tried replacing the file which doesn’t work because the entire folder is read-only, I have tried using a different text editor, I have tried re-installing the operating system. Nothing works. Any help would be greatly appreciated. Thank you! (:

i met many problem like like this
if it too difficult to this in linux, try some small windows pe (linux file permission is meaningless in windows)

I have tried editing it in windows, but when I plug in the USB it doesn’t show up. Any thoughts? Thanks! :smiley:

there should be at least a fat partition show up
are you make there no new partition show up when plug the usb (and use some partitioning software to check and mount)

I don’t see any partitions showing up ):

I’m not quite sure what you meat by that. Can you explain it again please?

It does not sound like a secure way to do things.

i know, i have experienced that, lot of time linux won’t let me do many thing because file permission and the only way is use something that think there weird bit meaningless and the most usable way is windows (now when i think about it, i call that my failure to transition to linux)

Do you know if there is any way I can safely edit the qubes os files on my usb thumb drive? I appreciate all the help you can provide (:

Laptop spec? have you try qubes 4.1

I am using a Razer Blade 14 2021. Qubes 4.1 was the first thing I tried because I didn’t know it wasn’t fully released until I scrolled down and saw the stable release. When I attempted to boot 4.1 I got to the boot menu (which looked odd, It didn’t have the usual blue color, It was just a black background.) and then any of the options I clicked would cause a boot loop.

I have tried a few more things. Let me explain my problem more thoroughly as I don’t think I have been clear enough. I recently purchased a Razer Blade 14 2021 edition laptop which sports 16GB of RAM, an AMD5900HX processor, an RTX 3060 laptop GPU, and 1TB of storage on an SSD.

When I received the laptop I disabled secure boot and enabled CPU virtualization.

When I first went to install Qubes OS I accidentally installed the test release labeled as Qubes-R4.1.0-rc2-x86_64.iso. When I booted it the result was the Qubes boot menu without the friendly blue background and Qubes logo, instead the background was completely black and the letters could be described as “pixely” no matter what option I selected on this menu, It would cause a boot loop.

A couple days later I realized I was booting the test release and attempted booting the stable release labeled as Qubes-R4.0.0-rc2-x86_64.iso. This resulted in no boot menu, rather some text scrolling by the screen followed by a completely black screen.

I did some research and from there what I tried was:

  1. Flashing the iso on a usb that is 8GB in capacity
  2. Booting in “legacy mode” (though I am not sure if I did it right)
  3. I attempted to figure out how to turn my GPU to “discrete only mode” (I could never find out how)
  4. Editing the ISO file to comment out “noexitboot” and “mapbs” and adding “noveau=1”. I was not able to edit this file because it kept telling me it was a read only file (no matter what permissions I had. I tried root)
  5. Extracting the files of the ISO, making the changes stated previously, and turning the folder back into a bootable ISO. My laptop did not recognize the file as bootable and it did not show up in my BIOS as an option.

All of the previously stated adjustments have been repeated several times to no avail. I have never successfully gotten to the normal Qubes boot menu that I have seen in YouTube videos and online. If there is any help that anybody can provide, it is appreciated more than you know. Thank you in advance! (:

I’d recommended to test in 4.1-rc2.

In grub menu, try editing grub config by pressing “e” then add modprobe.blacklist=nouveau after queit, then press f10 to boot.

as example see image below :

(Ignore i915…port=1)

I did this and I am still getting the boot loop. I flashed qubes 4.1-rc2 and went into the grub menu and added that. Text popped up on the screen that said “booting a command list” and then a black screen for a few seconds, and then the screen turned off for a few seconds, and then I was back at the grub menu.

Thank you for your time. I am just going to use a generic distro because I have spent weeks trying to figure this out and found no solution.

I might have this issue in qubes now with an usb device… Not sure…