Error while upgrading to 4.1


While upgrading to 4.1 using the command “sudo qubes-dist-upgrade --all -y” as per documentation, I encounter a (seemingly unavoidable) error during stage 1 during “updating Template VMs and StandaloneVMs…” which is an “ERROR: exit code 20” on whonix-gw-15 and whonix-ws-15 templates (all other templates are successfully updated).

Notably, I am not using Whonix 15, rather I am using version 16 have my own whonix-gw-16 and whonix-ws-16 templates that I run anon-whonix/sys-whonix through.

An intuitive solution would seem to be to simply delete whonix-gw-15 and whonix-ws-15 (as they are not needed anyways) however I receive this error when I attempt to delete either of these templates: “VM installed by package manager: whonix-gw-15”.

How can I go about either destroying these templates and preventing them from ever being required/re-downloaded again, or having the Qubes updater program ignore this dependency?

After the upgrade fails, I get the output “-> Launch restoration…”

sudo rpm -e qubes-template-xxx

This solved the issue, thanks!

1 Like