Error while installing Qubes OS 4.1


I have been trying to install Qubes OS 4.1 for several hours now without success.

I tried in UEFI mode, the installation goes well, but after reboot, impossible to start the OS, my SSD does not appear in the UEFI list.

I tried in LEGACY mode, and it is totally impossible to install it, I have an error “X startup failed”.

Here is my configuration:

Motherboard: MSI Tomahawk Z390
Processor: Intel-9600K
Graphics card: RTX 3070
RAM: 16 GB DDR4 3200 MHz

So I come to the forum hoping to find help.
Thanks in advance to all the people who will come and try to help me.

are you using external ssd ? if not, try create an uefi manager by booting into qubes os rescue (in your installation medium), skip to shell.

run :

  • lsblk (check out your SSD first)
    if it was /dev/sda then run this

efibootmgr -v -c -u -L "fantazy" -l /EFI/qubes/grubx64.efi -d /dev/sda -p 1

change /dev/sda with actual SSD block device.

Thank you for your answer.

I managed to solve the problem simply by disabling my graphics card and re-installing in Legacy mode, everything went smoothly.