Error on updating multiple templates (Failed to copy Salt configuration)

Nothing major has changed since my last boot of the machine. I previously updated with via the GUI updater many times with little to no issues. I am relatively new to Qubes OS, so maybe I am missing something obvious.

TS completed:
-reviewed the “How to update” Qubes OS page. Tried using the qubesctl commands but they wouldn’t work.
-read through “Update troubleshooting” page. Have not tried manual updates in template via sudo dnf upgrade or ‘apt-get’ because it is a security risk.
-looked through several forums here and was not able to find relevant information.

Issue at hand:

Error on updating fedora-33: Command '['sudo', 'qubesctl',
'--skip-dom0', '--targets=fedora-33, '--show-output', 'state.sls',
'update.qubes-vm']' returned non-zero exit status 1
fedora-33: ERROR (exception Failed to copy Salt configuration to disp-mgmt-fedora-33)

Error on updating whonix-gw-15: Command '['sudo', 'qubesctl',
'--skip-dom0', '--targets=whonix-gw-15', '--show-output', 'state.sls',
'update.qubes-vm']' returned non-zero exit status 1
whonix-gw-15: ERROR (exception Failed to copy Salt configuration to disp-mgmt-whonix-gw-15)

Error on updating whonix-ws-15: Command '['sudo', 'qubesctl',
'--skip-dom0', '--targets=whonix-ws-15', '--show-output', 'state.sls',
'update.qubes-vm']' returned non-zero exit status 1
whonix-ws-15: ERROR (exception Failed to copy Salt configuration to disp-mgmt-whonix-ws-15)

They’re only a security risk in the sense that if you always use them instead of Salt updates, you might miss out on special security updates that can be delivered only via Salt, which is somewhat rare relative to routine updates. They are not dangerous per se. In other words, on a normal, working system that performs Salt updates regularly, also using the direct update commands does no harm.

1 Like

You will have to provide much more information than this for anyone to be able to help. “Wouldn’t work” is as unspecific as it gets.

I don’t recall ever seeing these error messages before, but at the risk of sounding cliche, have you tried simply restarting your whole system?

@anon1 - Thanks for the report, and for having done some research
yourself.
Can you please confirm which template you are using for the
mgmt disposable?
You can get this information on a per qube basis with qvm-prefs.
qubes-prefs will show you the global management disposable.
qvm-prefs for that will show you the template used.

If you have not made any changes, then all qubes will be using the
global disposable, and that will be based on a standard template.

For future reference:
You have not said what version of Qubes you are using.
You have not said what template you are using for the management
disposable.
There’s little point in repeating the same information - you could have
summarised by saying “I am unable to update these (all?) templates -
updates fail with the error message ERROR (exception Failed to copy Salt
configuration to disp-mgmt-)”

“Nothing major” is unhelpful - what you think is minor may be the key to
the problem. So please summarise any changes you have made to the
system, since updates last worked.
It would be helpful if you confirmed that all templates are
affected.
It would be helpful if you confirmed that manual updates work. (There’s
no additional security risk here - salt is used to distribute patches
and configurations as well as updating - if you only perform manual
updates you miss out on these.)

Thank you for replying. I will keep your advice in mind and provide better documentation next time.

management_dispvm: default-mgmt-dvm
template: fedora-33
Qubes release 4.0
Since posting I have restarted my system again and the issue remains.
I have also updated each template manually via their terminals. Those updates proceeded without issue. I tried using the Qubes Updater after updating manually and the same errors as before return.

Before this issue appeared I allowed full access to internet for 5 minutes within the fedora 33 template in order to install package/required items to use in app vm. I do not recall which, maybe discord. Right after I set the networking back to none for the fedora 33 template.

@unman @adw

Thanks for the additional information - sorry for the delay in replying.

There is almost never any need to open a template to the network. There
is a proxy installed which can be used (abused) for almost every use case.

Do you have a clean copy of the fedora-33 template, or did you install
into the only copy?
Can you try setting the template for the default-mgmt-dvm to use a clean
fedora-33 (if you have one), or a debian template, and try to update a
single template? Report back progress.

I solved the problem last week by simply reinstalling a clean copy of the fedora-33 template as described here: http://qubesosfasa4zl44o4tws22di6kepyzfeqv3tg4e3ztknltfxqrymdad.onion/doc/how-to-reinstall-a-template/

After reinstalling the template the Qubes Updater works normally.