Error mounting exfat in debian 11

What’s required to mount exfat in debian 11? exfat-fuse and exfat-utils are included in debian so it should be automatic but I’m still getting errors.

are you using sys-usb ? and how you mount it ?

I have sys-usb. I tried mounting it there and also in a regular debian AppVM. I can format exfat and rw after the format but I can’t mount it if it has been unmounted, or any unmounted drive. I imagine I’m doing something wrong.

I have the same issue on my Debian 11 appVMs with a Samsung T5 SSD. Mounting in Nautilus now fails with the exfat failure error. Mounting manually also returns same error.
Never had the issue in Debian 10 appVMs. All exfat packages are installed in the 11 template I believe (exfat-fuse; exfat-utils)

Glad it’s not just me though I forgot debian-11 is still in testing.

debian 11 aka bullseye is released, not sure about the qubes version

I just downloaded 11 + minimal from sudo qubes-dom0-update --enablerepo=qubes-templates-itl-testing qubes-template-debian-11

so qubes version is still testing

Yes qubes debian

Thanks, you’re right it works on 10. I guess it’s not a huge setback to run a 10 minimal to mount drives.

I have raised an issue for this,
which is specific to the debian-11 template in 4.0 testing.

Thanks for identifying the problem @joe.blough

1 Like